Bug 1175705 - sssd-libwbclient conflicts with Samba's and causes crash in wbinfo
Summary: sssd-libwbclient conflicts with Samba's and causes crash in wbinfo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: SSSD Maintainers
QA Contact: Kaushik Banerjee
URL:
Whiteboard:
Depends On: 1175511
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-18 12:39 UTC by Sumit Bose
Modified: 2020-05-02 17:54 UTC (History)
11 users (show)

Fixed In Version: sssd-1.12.2-39.el7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1175511
Environment:
Last Closed: 2015-03-05 10:35:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github SSSD sssd issues 3579 None None None 2020-05-02 17:54:21 UTC
Red Hat Product Errata RHBA-2015:0441 normal SHIPPED_LIVE sssd bug fix and enhancement update 2015-03-05 15:05:27 UTC

Description Sumit Bose 2014-12-18 12:39:48 UTC
+++ This bug was initially created as a clone of Bug #1175511 +++

Description of problem:
wbinfo -K <user> causes a segfault

Version-Release number of selected component (if applicable):
4.1.13-1


How reproducible:
100%

Steps to Reproduce:
1. In cases where kerberos auth fails, do:
2. wbinfo -K <user>
3. 

Actual results:
Enter vverma7's password:
plaintext kerberos password authentication for [vverma7] failed (requesting cctype: FILE)
Segmentation fault (core dumped)

Expected results:


Additional info:

Backtrace:
(gdb) r
Starting program: /usr/bin/wbinfo -K vverma7
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Enter vverma7's password:
plaintext kerberos password authentication for [vverma7] failed (requesting cctype: FILE)

Program received signal SIGSEGV, Segmentation fault.
wbinfo_auth_krb5 (username=0x5555557625e0 "vverma7", cctype=0x55555555e588 "FILE", flags=28690)
    at ../nsswitch/wbinfo.c:1572
1572                    d_fprintf(stderr,
Missing separate debuginfos, use: debuginfo-install bzip2-libs-1.0.6-14.fc21.x86_64 libtdb-1.3.1-1.fc21.x86_64 libtevent-0.9.21-3.fc21.x86_64
(gdb) bt
#0  wbinfo_auth_krb5 (username=0x5555557625e0 "vverma7", cctype=0x55555555e588 "FILE", flags=28690)
    at ../nsswitch/wbinfo.c:1572
#1  0x00005555555584bb in main (argc=<optimized out>, argv=<optimized out>, envp=<optimized out>)
    at ../nsswitch/wbinfo.c:2557
(gdb) p *error
Cannot access memory at address 0x1
(gdb) q

--- Additional comment from David Woodhouse on 2014-12-17 18:56:21 EST ---

Oh, this system has sssd-libwbclient installed, and it was using that. Removing it makes it use the real libwbclient which works.

--- Additional comment from David Woodhouse on 2014-12-17 19:04:35 EST ---

If you're going to install a higher-priority 'alternative' for Samba's libraries, please make sure they *work*.

Comment 3 Martin Kosek 2014-12-19 10:46:42 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2537

Comment 5 David Woodhouse 2014-12-19 21:51:03 UTC
This doesn't look like it fixes things. It stops wbinfo from *crashing*, sure. But it still doesn't *work*.

Comment 8 errata-xmlrpc 2015-03-05 10:35:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0441.html


Note You need to log in before you can comment on or make changes to this bug.