Bug 1175793 - [hosted-engine] setup fails with "Failed to execute stage 'Misc configuration': image_uuid or volume_uuid is missing or None"
Summary: [hosted-engine] setup fails with "Failed to execute stage 'Misc configuration...
Keywords:
Status: CLOSED DUPLICATE of bug 1171452
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha
Version: 3.5.0
Hardware: x86_64
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Doron Fediuck
QA Contact: meital avital
URL:
Whiteboard: integration
Depends On:
Blocks: rhev35rcblocker
TreeView+ depends on / blocked
 
Reported: 2014-12-18 15:32 UTC by Elad
Modified: 2014-12-19 09:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-19 09:50:40 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
logs from the host (4.62 MB, application/x-gzip)
2014-12-18 15:32 UTC, Elad
no flags Details

Description Elad 2014-12-18 15:32:18 UTC
Created attachment 970626 [details]
logs from the host

Description of problem:
hosted-engine deployment fails everytime using iSCSI and NFS.

[ INFO  ] Verifying sanlock lockspace initialization
[ ERROR ] Failed to execute stage 'Misc configuration': image_uuid or volume_uuid is missing or None
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20141218172040.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination


Version-Release number of selected component (if applicable):
rhev 3.5 vt13.4
rhel6.6
ovirt-hosted-engine-ha-1.2.4-4.el6ev.noarch
ovirt-hosted-engine-setup-1.2.1-8.el6ev.noarch
vdsm-4.16.8.1-4.el6ev.x86_64
sanlock-2.8-1.el6.x86_64
selinux-policy-3.7.19-260.el6_6.1.noarch
libvirt-0.10.2-46.el6_6.2.x86_64
qemu-kvm-rhev-0.12.1.2-2.448.el6.x86_64

How reproducible:
Always, using rhel6.6 with both iSCSI and NFS

Steps to Reproduce:
1. deploy hosted engine, use iSCSI or NFS
2.
3.

Actual results:
Deployment fails with the following exception:

20**FILTERED**4-**FILTERED**2-**FILTERED**8 **FILTERED**7:**FILTERED**5:5**FILTERED** DEBUG otopi.context context._executeMethod:**FILTERED**52 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line **FILTERED**42, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/sanlock/lockspace.py", line **FILTERED**50, in _misc
    **activate_devices
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/lib/storage_backends.py", line 228, in __init__
    activate_devices.items()
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/lib/storage_backends.py", line 227, in <lambda>
    (service, self.Device.device_from_str(device)),
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/lib/storage_backends.py", line **FILTERED**93, in device_from_str
    dev = cls(None, None, None)
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/lib/storage_backends.py", line **FILTERED**52, in __init__
    "image_uuid or volume_uuid is missing or None"
ValueError: image_uuid or volume_uuid is missing or None
20**FILTERED**4-**FILTERED**2-**FILTERED**8 **FILTERED**7:**FILTERED**5:5**FILTERED** ERROR otopi.context context._executeMethod:**FILTERED**6**FILTERED** Failed to execute stage 'Misc configuration': image_uuid o
r volume_uuid is missing or None



Expected results:
Deployment should succeed.

Additional info:
logs from the host

Comment 1 Sandro Bonazzola 2014-12-19 09:50:40 UTC
Elad thanks for reporting. this was introduced as regression while fixing bug #1171452 and already addressed there.

I see you're using ovirt-hosted-engine-ha-1.2.4-4.el6ev.noarch, the fix is in ovirt-hosted-engine-ha-1.2.4-5.el6ev.noarch

Closing as duplicate.

*** This bug has been marked as a duplicate of bug 1171452 ***


Note You need to log in before you can comment on or make changes to this bug.