Bug 117581 - Include patch for intel 845G BIOS refresh rate bug
Include patch for intel 845G BIOS refresh rate bug
Status: CLOSED DUPLICATE of bug 116040
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-03-05 11:07 EST by Paul Pianta
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:01:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Paul Pianta 2004-03-05 11:07:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
i am running fedora core 1 on my dell with an intel 845G video
chipset. The monitor refresh rate is locked at 60 Hz (ouch my eyes go

There is a bug report for fc1 (#116040) but i am making a report in
the hope that the fix can be included in fc2.

My co-worker with the same machine has installed XFree86-4.4 from
source and the bug is fixed in that version ... but i know 4.4 is
ruled out in fc2 - so maybe a patched 4.3 ?

I downloaded XFree86-4.3.0-62.src.rpm from rawhide (dated 01-Mar-2004
01:45) and checked if the fix was in there and unfortunately it
wasn't. I hope it was ok that i checked the rawhide version and not
the 4.3.0-45 which is included with fc2-test1 ... I figure if its not
in version 62 it's not likely to be in 45 ;)

Here is the link to the fix (from 25 Jan 2004) on XFree86's cvs web site:

Let me know if you need any more details ...

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Run fc2-test1 and X on a dell machine with the intel 845G video chipset

Actual Results:  can only ever get 60Hz refresh rate

Expected Results:  can choose whatever refresh rate i want

Additional info:

some more detailed info from the guy who submitted the fix to XFree86

Comment 1 Mike A. Harris 2004-03-05 14:00:57 EST
Thanks for reporting this issue.  I'm going to mark this as a
duplicate of the other bug report, as we can track the issue in one
place easier that way, since it will be fixed in all OS releases
at the same time if a fix gets incorporated into the 4.3.0 packaging
as we share the src.rpm across all OS releases.

Thanks again.

*** This bug has been marked as a duplicate of 116040 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.