Bug 117584 - L440GX+ plus aic7xxx plus DAC960 = won't boot
L440GX+ plus aic7xxx plus DAC960 = won't boot
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-03-05 11:26 EST by Robert Haas
Modified: 2015-01-04 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-16 01:54:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Robert Haas 2004-03-05 11:26:42 EST
Description of problem:
I have a VALinux server with an L440GX+ motherboard.  FC1 tries to 
load aic7xxx driver, which hangs for a looooooooong time, then 
eventually DAC960 driver, which hangs forever

Steps to Reproduce:
1. Insert Fedora Core 1 binary CD #1 into above machine.
2. Boot.
Actual results:
Anaconda hangs while loading aic7xxx driver.  After a looooooooong 
time, it apparently succeeds and moves on to the DAC960 driver, which 
hangs as well, apparently forever.

Expected results:
Drivers load and I can install FC1.

Additional info:
I've looked through various previously-filed bugzillas on similar 
topics for previous RedHat releases going back to RH7.1.  Although it 
seems that some related problems may have been fixed, this one 
clearly hasn't.  I've tried booting with `apic', `noapic', and 
`apic=force' and none of these seem to change anything.  If I boot 
with `noprobe' and then load ONLY the DAC960 driver (skipping the 
aic7xxx driver), it doesn't hang and I can install.
Comment 1 Philip Tait 2004-05-24 17:53:38 EDT
Update: this occurs with Fedora Core 2, and without the DAC960. (SuSE
9.1 and Mandrake 10 can be installed successfully on the same system.)
Comment 2 David Lawrence 2004-09-29 16:09:49 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/
Comment 3 Robert Haas 2004-09-30 17:25:31 EDT
As comment 1 clearly states, this bug (or a very similar bug) exists 
in FC2 even without the DAC960.  The original report alludes to the 
fact that related problems seem to have been occurring since as far 
back as RH7.1, as was revealed by the extensive bugzilla search that 
I carried out before filing the original bug.  I'm sure that you guys 
are very busy, but there's not a lot of incentive to file bug reports 
if they're going to be automatically closed after six months 
(apparently) without ever having been read.

I just tried this again with FC2 on the system on the basis of which 
I originally filed the bug.  FC2 tries to load the DAC960 driver 
(succesfully) but then tries to load aic7xxx driver and hangs, if not 
forever, then at least for a really long time.  So the problem is 
slightly different, but the effect is substantively the same: this 
hardware configuration does not work.  I also tried this again with 
the "apic" and "noapic" options; it is still the case that neither 
option helps.
Comment 4 David Rossiter 2004-11-06 11:06:23 EST
I'm having exactly the same issue with my N440BX motherboard.

I'm currently having to run a non SMP kernel, meaning my dual 
processor system isn't fully utilized, and my plans for raid 
redundancy are hindered.

I had to install fedora on another machine then transfer the IDE hard 
disk over, as both Core 1 and 2 installations hang when trying to 
load DAC960.

Maybe I'm wrong, but I thought Linux was about sorting out problems. 
If I wanted to be forced into the newest software to even be 
considered then I would have got a Mac.
Comment 5 Erik Parker 2004-11-06 17:07:51 EST
identical issue found with another VALinux Box. Same motherboard as
original reported, locks on AIC7xxx driver load.. At least after an
hour, it hasn't done anything. It isn't hard locked, you can view
alt-f3 and alt-f4, however it only shows it's loaded the scsi driver..
and sits. As if it were contemplating its place in life.
Comment 6 Dave Jones 2005-04-16 01:54:17 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.
Comment 7 Robert Haas 2005-04-16 12:42:50 EDT
Alternatively, maybe we should just switch to a different distro.  Give me a break.

Note You need to log in before you can comment on or make changes to this bug.