Bug 1175885 - [RFE] Ability to deep-merge hashes and arrays in SmartClass parameters
Summary: [RFE] Ability to deep-merge hashes and arrays in SmartClass parameters
Keywords:
Status: CLOSED DUPLICATE of bug 1010575
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Configuration Management
Version: 6.0.6
Hardware: All
OS: Linux
low
low
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-18 20:07 UTC by Chris Roberts
Modified: 2019-09-12 08:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-14 21:08:21 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)

Description Chris Roberts 2014-12-18 20:07:51 UTC
Hello!

We are today using hiera and using the hiera_hash and hiera_array to
create deep-merges hash and array data and we would like similar
functionality in Satellite 6, in SmartClass parameters
To give an example, we would like the ability to create the following
hash in a HostGroup

serversettings:
  VCN-AD: 
    nisdomain: vcn.ds.volvo.net
    srvdomain: SE-GOT._sites.vcn.ds.volvo.net
  XYZ-AD:
    nisdomain: xyz.ds.volvo.net
    srvdomain: SE-GOT._sites.xyz.ds.volvo.net

Then on an individual Host, we would like the ability to override a
single key of the hash by specifying a hash like the one below and
marking that the hashes should be merged rather the overridden

serversettings:
  VCN-AD:
    nisdomain: vcnqalab.dsqalab.volvo.net
    srvdomain: SE-GOT._sites.vcnqalab.dsqalab.volvo.net

The resulting hash should then be

serversettings:
  VCN-AD: 
    nisdomain: vcnqalab.dsqalab.volvo.net
    srvdomain: SE-GOT._sites.vcnqalab.dsqalab.volvo.net
  XYZ-AD:
    nisdomain: xyz.ds.volvo.net
    srvdomain: SE-GOT._sites.xyz.ds.volvo.net


We would also need the same functionality for arrays.

Comment 2 RHEL Program Management 2014-12-18 20:24:10 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 David Juran 2015-01-07 15:23:25 UTC
I think this is a dup of Bz 1010575

Comment 5 Bryan Kearney 2015-04-14 21:08:21 UTC
David is correct, closing this.

*** This bug has been marked as a duplicate of bug 1010575 ***


Note You need to log in before you can comment on or make changes to this bug.