Bug 117598 - Cancel button on Search screen doesn't do anything
Cancel button on Search screen doesn't do anything
Status: CLOSED WONTFIX
Product: Red Hat Enterprise CMS
Classification: Retired
Component: ui (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Daniel Berrange
:
Depends On:
Blocks: 113496
  Show dependency treegraph
 
Reported: 2004-03-05 13:11 EST by Char James-Tanny
Modified: 2010-09-03 10:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-03 10:31:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Char James-Tanny 2004-03-05 13:11:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
In the CMS, using the Search database, click the Cancel button and the
current screen is redisplayed (Search or Matches). It should return to
the previous screen that the user was on.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Click Add foo. The Search screen is displayed.
2. Click Cancel. The Search screen is redisplayed.

1. Click Add foo. The Search screen is displayed.
2. Type search terms or %.
3. Click Search. The Matches screen is displayed.
4. Click Cancel. The Matches screen is redisplayed.
    

Actual Results:  The current screen is redisplayed.

Expected Results:  The previous screen should be displayed.

Additional info:
Comment 1 Richard Li 2004-03-05 13:32:02 EST
I think this referring to the add a new member to a role screen. Once
the search displays a list of results, the cancel button does not work. 
Comment 2 Char James-Tanny 2004-03-09 13:12:17 EST
Not always...see first steps above:

1. Click Add foo. The Search screen is displayed.
2. Click Cancel. The Search screen is redisplayed.

In this case, all I did was click Add and then click Cancel. No search
results, nothing, just clicked Cancel and redisplayed the same screen
I'm on.
Comment 3 Justin Ross 2004-03-11 17:59:36 EST
Perforce change 41289 addresses the problem that Richard found.  Char,
I'm not sure which search screen you refer to.  Is this all in the
Roles pane?  What's the UI context of the operations described in your
comment #2 above?
Comment 4 Char James-Tanny 2004-03-18 12:39:56 EST
OK, I've found this in Workflows when assigning members to a
task...looks like Roles got fixed :-) 

In Workflows, click Assign User in Task Details for a task. The Search
to Add New Members section is displayed. Immediately click Cancel. I
get very interesting results....I see all users in this content
section. Click Cancel again and return to the previous screen.

If there's something in the Search field, the Matches are continuously
redisplayed when I click Cancel.

Note You need to log in before you can comment on or make changes to this bug.