Bug 117601 - Inappropriate dependencies (qt-devel) in latest kernel-source .rpm
Inappropriate dependencies (qt-devel) in latest kernel-source .rpm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-05 13:25 EST by ajs
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-05 13:52:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ajs 2004-03-05 13:25:36 EST
kernel-source-2.6.3-2.1.238 requires qt-devel:  A bad situation for a
headless server with small hard drive
Comment 1 Arjan van de Ven 2004-03-05 13:27:12 EST
I wouldn't expect you to want to recompile your kernel on a headless
server with a small hard drive, after all the kernel source is huge
already. make xconfig requires qt-devel.....
Comment 2 ajs 2004-03-05 13:40:08 EST
I don't want to compile the _KERNEL_.  I need to compile some external
drivers.  If I wanted to build the kernel I'd use the .src.rpm.  The
machine I would do that on a different compute that, in any case, 
does not have many GUI applications on it.

Why not just split out a sub-package called kernel-source-xconfig that
depends on qt-devel?
Comment 3 Arjan van de Ven 2004-03-05 13:41:30 EST
ehm you cannot use kernel-source for building external drivers
against.... all the bits for that are already part of the normal
kernel(-smp) rpm.

sounds like that is the misconception here...
Comment 4 ajs 2004-03-05 13:52:56 EST
cool. (rpm -e kernel-source).

Note You need to log in before you can comment on or make changes to this bug.