Bug 1176050 - libvirt emitted a invalid option "-bootloader" to qemu-kvm
Summary: libvirt emitted a invalid option "-bootloader" to qemu-kvm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.1
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ján Tomko
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1212339
TreeView+ depends on / blocked
 
Reported: 2014-12-19 09:49 UTC by Hu Jianwei
Modified: 2015-11-19 06:05 UTC (History)
5 users (show)

Fixed In Version: libvirt-1.2.14-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1212339 (view as bug list)
Environment:
Last Closed: 2015-11-19 06:05:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description Hu Jianwei 2014-12-19 09:49:47 UTC
Description of problem:
libvirt emitted a invalid option "-bootloader" to qemu-kvm

Version-Release number of selected component (if applicable):
libvirt-1.2.8-11.el7.x86_64
qemu-kvm-rhev-2.1.2-17.el7.x86_64

How reproducible:
100%

Steps to Reproduce:

[root@ibm-x3850x5-06 ~]# virsh dumpxml r7| grep bootloader -a4
  <vcpu placement='static'>2</vcpu>
  <resource>
    <partition>/machine</partition>
  </resource>
  <bootloader>/usr/bin/pygrub</bootloader>
  <bootloader_args>--append single</bootloader_args>
...

[root@ibm-x3850x5-06 ~]# virsh list --all
 Id    Name                           State
----------------------------------------------------
 -     r7                             shut off

[root@ibm-x3850x5-06 ~]# virsh start r7
error: Failed to start domain r7
error: internal error: process exited while connecting to monitor: qemu-kvm: -bootloader: invalid option


Actual results:
As shown above steps.

Expected results:
qemu-kvm does not support this option, so libvirt should not emit such option to qemu CLI.

Additional info:
[root@ibm-x3850x5-06 libvirt-1.2.8]# /usr/libexec/qemu-kvm -h | grep bootloader
[root@ibm-x3850x5-06 libvirt-1.2.8]#
[root@ibm-x3850x5-06 libvirt-1.2.8]#  < nothing output

Comment 2 Ján Tomko 2015-02-18 16:40:07 UTC
Upstream patch:
https://www.redhat.com/archives/libvir-list/2015-February/msg00662.html

Comment 4 Ján Tomko 2015-03-02 06:51:48 UTC
Pushed upstream:
commit 9aa316612aa74abf88b3eb97e1a0eda920dab94a
Author:     Ján Tomko <jtomko@redhat.com>
CommitDate: 2015-03-02 07:39:09 +0100

    Remove bootloader option from QEMU
    
    It was only supported by xenner (since commit 763a59d8),
    for which we removed support in commit de9be0a.
    
    Remove the code generating this command line option,
    refuse to parse it and delete the outdated tests.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1176050

git describe: v1.2.13-2-g9aa3166

Comment 8 Shanzhi Yu 2015-07-16 07:44:05 UTC
Verify this bug with 
libvirt-1.2.17-2.el7.x86_64
qemu-kvm-rhev-2.3.0-9.el7.x86_64


1. Prepare xml file with bootload options.

# cat r7.xml |grep bootload -A 2 
  <bootloader>/usr/bin/pygrub</bootloader>
    <bootloader_args>--append single</bootloader_args>
  <clock offset='utc'/>

2. Try to define guest with above guest 

# virsh define r7.xml 
error: Failed to define domain from r7.xml
error: unsupported configuration: bootloader is not supported by QEMU


# /usr/libexec/qemu-kvm -h | grep bootloader

Comment 10 errata-xmlrpc 2015-11-19 06:05:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.