Bug 117607 - 4G/4G breaks ACPI S3 sleep
4G/4G breaks ACPI S3 sleep
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: FC2Target 117690
  Show dependency treegraph
 
Reported: 2004-03-05 14:21 EST by Bill Nottingham
Modified: 2014-03-16 22:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-20 07:19:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2004-03-05 14:21:05 EST
Description of problem:

When resuming from ACPI sleep, the machine just reboots.

Version-Release number of selected component (if applicable):

2.6.3-2.1.238

How reproducible:

So far happened the first time. Presumably it will happen on
subsequent tries.

Steps to Reproduce:
1. echo "3" > /proc/acpi/sleep
2. <suspend>
3. hit power button to resume
  
Actual results:

Rebooted

Expected results:

Resumes

Additional info:

2.6.2-1.87 was last known working good... hadn't actually updated in a
while.
Comment 1 Arjan van de Ven 2004-03-07 03:20:33 EST
this looks like a 4g/4g interaction; does the i586 kernel work in 242 ?
Comment 2 Warren Togami 2004-03-07 03:25:58 EST
2.6.3-1.118 before the davej+arjan kernel merge was the last working
kernel in this regard.  I have tracked it down to the 4G/4G split from
-mm activated in 2.6.3-2.[236-242].  Workaround: You can either
disable the 4G/4G and rebuild i686 for yourself, or use the i586
kernel which has this feature disabled.

(Note: This also breaks vmware 4.0.5's module, but vmware upstream can
probably easily fix that problem.  Not our problem.)
Comment 3 Warren Togami 2004-03-19 15:52:06 EST
All kernels up through kernel-2.6.4-1.275 are still affected by this
issue.
Comment 4 Nils Philippsen 2004-03-25 06:40:43 EST
Is this the same as #117032?
Comment 5 Bill Nottingham 2004-03-25 09:45:16 EST
The instant-reboot is almost certianly the same bug.
Comment 6 Arjan van de Ven 2004-04-20 07:19:10 EDT
fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.