Bug 11761 - Password similarity checking
Summary: Password similarity checking
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cracklib   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-30 15:14 UTC by selleck
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-30 15:14:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description selleck 2000-05-30 15:14:18 UTC
When used by PAM to check passwords, a 6 character password being changed
to a 20 character password gives a "too similar" error because of the
number of similar letters.  THere should be an option to have the
similarity 'score' reduced based on the length of the new password.

eg:
password -> swordfish
... new password is "too similar" ... but not very long either.
password -> aswordfishatemyboat
... still too similar?

Comment 1 Nalin Dahyabhai 2000-07-10 19:43:35 UTC
When md5 passwords are not being used, the effective password
length is 8.  The words "swordfis" and "aswordfi" are indeed similar.


Note You need to log in before you can comment on or make changes to this bug.