Bug 117618 - kernel or boot process installs ip1394 module during boot
Summary: kernel or boot process installs ip1394 module during boot
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-05 20:55 UTC by Thomas J. Baker
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-05 21:06:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas J. Baker 2004-03-05 20:55:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040217 Galeon/1.3.12

Description of problem:

When booting this new kernel, the ip1394 module is loaded, claiming
eth0, and then there is a failure to configure eth0 because when the
e1000 driver is loaded, it gets put at eth1. Here is some of the
kernel log:

Mar  5 10:57:40 wintermute kernel: ip1394: $Rev: 1175 $ Ben Collins
<bcollins@debian.org>
Mar  5 10:57:40 wintermute kernel: ip1394: eth0: IEEE-1394 IPv4 over
1394 Ethernet (fw-host0)

This doesn't happen with the 2.6.3-1.118smp which I'm running now. I
can provide more info if this is not a known problem. I searched
bugzilla but didn't see anything like this.

By the way, I'm running this on a Dell 650N Dual 3GHz Xeon with an
e1000 eth.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.3-2.1.238

How reproducible:
Always

Steps to Reproduce:
1. install new kernel
2. reboot
3.
    

Actual Results:  
ip1394 module is loaded during boot 

Expected Results:  ip1394 module is not loaded

Additional info:

Comment 1 Bill Nottingham 2004-03-05 21:06:11 UTC
The eth1394 module will be disabled in modutils-2.4.26-7, while we
debate 'better' ways to fix this.


Note You need to log in before you can comment on or make changes to this bug.