Bug 117625 - xsane cannot find device
xsane cannot find device
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xsane (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-05 17:37 EST by Frank Schmidt
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-06 16:47:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Frank Schmidt 2004-03-05 17:37:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1

Description of problem:
Hi, 

I am on Fedora CORE 1 Kernel 2.4.22-1.2166.nptl the rest is
upgrade to newest and greatest. 
My printer/scanner is HP PSC 2175. 

Problem:

try to run xsane.
  
Actual results:
"No devices available"

Reproducibility:
100%

Expected results:
Xsane should find the scanner and use it.

Looks like Error #110174 but is not! I tried
to follow the advice given in the Comments to that Error but to no
avail. The sane related installed packages are:

xsane-gimp-0.91-1
sane-frontends-1.0.11-3
sane-backends-devel-1.0.12-4
sane-backends-1.0.12-4
xsane-0.91-1
libsane-hpoj-0.90-19

I find my scanner with "sane-find-scanner"
found USB scanner (vendor=0x03f0 [Hewlett-Packard], product=0x2b11
[PSC 2170 Series]) at libusb:001:005

However "scanimage -L" finds nothing.

The same device is also a printer installed with CUPS and works fine
as such.

It has to be noted that xsane works with the same scanner on the same
machine on another partition with the kernel: 2.4.20-18.7.cern



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
try to run xsane.


Actual Results:  "No devices available"


Expected Results:  Xsane should find the scanner and use it.


Additional info:
Comment 1 Frank Schmidt 2004-03-05 22:03:34 EST
Hi,

After googling I finally found the solution at:

http://user.web.cern.ch/user/cern.html

and I followed step:

   3.

      An extra step is necessary before the printer configuration tool
will be able to set up your multifunction device (bug #88086)

      First of all you will need to become the root user with 'su -',
run 'service hpoj setup' in a terminal, and follow the instructions.

      Then run 'chkconfig hpoj on' and 'service hpoj start'.

Strange that the printer worked without this??

I guess the case is closed. Sorry, if somebody looked at it in the
meantime... Cheers, Frank

Comment 2 Frank Schmidt 2004-03-05 23:14:44 EST
Sorry again! The location is of course:

http://cyberelk.net/tim/hpoj.html

My last for today: I am left with the problem that after a reboot or
after scanning I have to switch off/on the device to use it as a
printer. I had that feature at RedHat 7.3 already. One can live with
that however...

Cheers, Frank 

Note You need to log in before you can comment on or make changes to this bug.