Bug 1176311 - glfs_h_creat() leaks file descriptors
Summary: glfs_h_creat() leaks file descriptors
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 3.4.6
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
Assignee: Niels de Vos
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On: 1176242
Blocks: glusterfs-3.4.7
TreeView+ depends on / blocked
 
Reported: 2014-12-20 10:24 UTC by Niels de Vos
Modified: 2015-03-05 22:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1176242
Environment:
Last Closed: 2014-12-20 10:32:42 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2014-12-20 10:24:54 UTC
+++ This bug was initially created as a clone of Bug #1176242 +++

Description of problem:
When running stress and performance tests against nfs-ganesha, the 
number of open file descriptors increases continously. If the tests run 
long enough, the brick processes will eventually run out of file
descriptors.


Version-Release number of selected component (if applicable):
current master and older versions that have glfs_h_creat()

How reproducible:
100%

Steps to Reproduce:
1. setup nfs-ganesha to export a (single brick) volume
2. create files on an nfs mountpoint
3. check the open file descriptors of the brick process

Actual results:
See the file descriptors of the brick process increase...

Expected results:
Increasing number of descriptors, but see it reduce again too.

Additional info:
This seems to be caused by glfs_h_creat() which allocates a 'struct
glfs_fd', but does not release it. A normal glfs_creat() returns the
file descriptor to the application, whereas glfs_h_creat() returns a
handle (struct glfs_object). The file descriptor associated with the
handle can not be release by glfapi-applications.

--- Additional comment from Anand Avati on 2014-12-19 21:08:06 CET ---

REVIEW: http://review.gluster.org/9318 (gfapi: always close the fd in glfs_h_creat()) posted (#2) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2014-12-20 11:21:01 CET ---

COMMIT: http://review.gluster.org/9318 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 0e78a12381e988a06e1d5a2dd592d132e24a4e10
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Dec 19 18:27:14 2014 +0100

    gfapi: always close the fd in glfs_h_creat()
    
    When running stress and performance tests against nfs-ganesha, the
    number of open file descriptors increases continously. If the tests run
    long enough, the brick processes will eventually run out of file
    descriptors.
    
    This seems to be caused by glfs_h_creat() which allocates a 'struct
    glfs_fd', but does not release it. A normal glfs_creat() returns the
    file descriptor to the application, whereas glfs_h_creat() returns a
    handle (struct glfs_object). The file descriptor associated with the
    handle can not be release by glfapi-applications.
    
    This fd-leak can be prevented by destroying the 'struct glfs_fd' before
    returning the 'struct gfls_object' to the gfapi-application.
    
    Change-Id: I32465077a35cd0449a8e584c53899b32f022e5af
    BUG: 1176242
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/9318
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 1 Niels de Vos 2014-12-20 10:32:42 UTC
It seems that the fd-leak was introduced with http://review.gluster.org/8333, and that is not part of this version.


Note You need to log in before you can comment on or make changes to this bug.