Bug 1176327 - SELinux is preventing /usr/libexec/Xorg.bin from 'write' accesses on the directory /tmp.
Summary: SELinux is preventing /usr/libexec/Xorg.bin from 'write' accesses on the dire...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:56d4cba5333d30788fe84d68a44...
: 1171426 1175173 1176779 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-20 15:04 UTC by z.d
Modified: 2015-01-30 23:54 UTC (History)
10 users (show)

Fixed In Version: selinux-policy-3.13.1-105.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-30 23:54:57 UTC
Type: ---


Attachments (Terms of Use)

Description z.d 2014-12-20 15:04:18 UTC
Description of problem:
$ optirun CoolVLViewer-1.26.12/cool_vl_viewer

[  388.945292] [ERROR]Cannot access secondary GPU - error: X unresponsive after 10 seconds - aborting


SELinux is preventing /usr/libexec/Xorg.bin from 'write' accesses on the directory /tmp.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that Xorg.bin should be allowed write access on the tmp directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep Xorg.bin /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:bumblebee_t:s0
Target Context                system_u:object_r:tmp_t:s0
Target Objects                /tmp [ dir ]
Source                        Xorg.bin
Source Path                   /usr/libexec/Xorg.bin
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xorg-x11-server-Xorg-1.16.2.901-1.fc21.x86_64
Target RPM Packages           filesystem-3.2-28.fc21.x86_64
Policy RPM                    selinux-policy-3.13.1-103.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.17.6-300.fc21.x86_64 #1 SMP Mon
                              Dec 8 22:29:32 UTC 2014 x86_64 x86_64
Alert Count                   6
First Seen                    2014-12-20 15:55:32 CET
Last Seen                     2014-12-20 15:55:42 CET
Local ID                      931e53d7-6eee-4960-af95-e10664e0eca9

Raw Audit Messages
type=AVC msg=audit(1419087342.785:427): avc:  denied  { write } for  pid=2515 comm="Xorg.bin" name="/" dev="tmpfs" ino=11599 scontext=system_u:system_r:bumblebee_t:s0 tcontext=system_u:object_r:tmp_t:s0 tclass=dir permissive=0


type=SYSCALL msg=audit(1419087342.785:427): arch=x86_64 syscall=open success=no exit=EACCES a0=7fff800a4770 a1=c1 a2=1a4 a3=8 items=0 ppid=659 pid=2515 auid=4294967295 uid=0 gid=1001 euid=0 suid=0 fsuid=0 egid=1001 sgid=1001 fsgid=1001 tty=(none) ses=4294967295 comm=Xorg.bin exe=/usr/libexec/Xorg.bin subj=system_u:system_r:bumblebee_t:s0 key=(null)

Hash: Xorg.bin,bumblebee_t,tmp_t,dir,write

Version-Release number of selected component:
selinux-policy-3.13.1-103.fc21.noarch

Additional info:
reporter:       libreport-2.3.0
hashmarkername: setroubleshoot
kernel:         3.17.6-300.fc21.x86_64
type:           libreport

Comment 1 Daniel Walsh 2014-12-23 20:06:59 UTC
Should bumblebee_t be transitioning to xserver_t?

Comment 2 Miroslav Grepl 2015-01-06 12:46:47 UTC
*** Bug 1176779 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2015-01-06 12:46:51 UTC
*** Bug 1171426 has been marked as a duplicate of this bug. ***

Comment 4 Miroslav Grepl 2015-01-06 12:48:32 UTC
commit 03f58844e96ec89e32eded1f385de6d203b9f9e8
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Tue Jan 6 11:30:12 2015 +0100

    Label /usr/libexec/Xorg.bin as xserver_exec_t.

Comment 5 Miroslav Grepl 2015-01-06 14:53:38 UTC
*** Bug 1175173 has been marked as a duplicate of this bug. ***

Comment 6 Julien HENRY 2015-01-26 14:46:39 UTC
Description of problem:
optirun glxgears

Additional info:
reporter:       libreport-2.3.0
hashmarkername: setroubleshoot
kernel:         3.17.8-300.fc21.x86_64
type:           libreport

Comment 7 Fedora Update System 2015-01-27 16:49:35 UTC
selinux-policy-3.13.1-105.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/selinux-policy-3.13.1-105.fc21

Comment 8 Fedora Update System 2015-01-30 04:32:30 UTC
Package selinux-policy-3.13.1-105.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.13.1-105.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1337/selinux-policy-3.13.1-105.fc21
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-01-30 23:54:57 UTC
selinux-policy-3.13.1-105.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.