Bug 1176364 - Increasing timeout ?
Increasing timeout ?
Status: CLOSED CURRENTRELEASE
Product: Copr
Classification: Community
Component: backend (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-20 18:40 EST by Nik Thom
Modified: 2016-01-05 11:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-03 13:15:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nik Thom 2014-12-20 18:40:04 EST
Description of problem:
I have multiple failed builds due to timeout, as I can understand. I'm trying to build a kernel, but it fails always and I cannot see any errors in build.log. 

 
Check this build.log:
http://copr-be.cloud.fedoraproject.org/results/nickth/kernel-bfq/fedora-20-x86_64/kernel-3.17.7-999.fc20/build.log


How reproducible:
I don't know if this is reproducible, but try to build a kernel with some additional patches. Though I don't think the additional patches is the problem, but the timeout. 

Can we please increase the timeout ? Is this applicable ? 

I can build the exact same kernel local, without problems. Yes, it takes too long to pass this specific point (warning) 

"drivers/scsi/advansys.c:71:2: warning: #warning this driver is still not properly converted to the DMA API [-Wcpp]
 #warning this driver is still not properly converted to the DMA API" 

but it passes it. 
In COPR, it just fails and I think is due to timeout.
Comment 1 Valentin Gologuzov 2015-01-05 10:17:04 EST
Found bug, fixing ...
Comment 2 Orion Poplawski 2015-12-30 18:15:08 EST
6 hours appears to be too short to build a kernel - all my build fail - 

https://copr.fedoraproject.org/coprs/orion/gfortmod/builds/
Comment 3 Miroslav Suchý 2016-01-03 13:15:23 EST
Changed in commit in infra.git
  a1b36fbbe77ea2cae9cd35d67619fab3beea19af
timeout to:
-timeout=21600
+timeout=33600

This is value which use Koji as well.
Comment 4 Orion Poplawski 2016-01-05 11:41:13 EST
Looks like this hasn't been put into production yet though?  I'm still timing out after 6 hours - https://copr-fe.cloud.fedoraproject.org/coprs/orion/gfortmod/build/151400/

Note You need to log in before you can comment on or make changes to this bug.