Bug 1176402 - already provided old password is used to connect to ISCSI target although a different password was provided in a newly added connection
Summary: already provided old password is used to connect to ISCSI target although a d...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Liron Aravot
QA Contact: Elad
URL:
Whiteboard:
Depends On: 1220824
Blocks: 1176578
TreeView+ depends on / blocked
 
Reported: 2014-12-21 12:22 UTC by Liron Aravot
Modified: 2016-03-10 12:03 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1176578 (view as bug list)
Environment:
Last Closed:
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 36320 master MERGED core: find connections with same password Never

Description Liron Aravot 2014-12-21 12:22:43 UTC
Description of problem:
If connection exists with some details (username/port/portal/connection/iqn/password) when adding a new lun with the same connection details but with different password (which may be correct opposed to the saved password) the old connection will be used for the LUN and new one won't be added, leading to use the old saved password to the newly added lun.

How reproducible:
Always


Steps to Reproduce:
1. Create a LUN disk through REST-API with wrong password.
2. try to add a domain/disk using the same connection details as the disk, but with the correct password.
3. the connection that'll be used for the newly added domain/disk is the one as the lun disk - instead of having a new connection with the new details.

Actual results:
the lun is added as using the old connection

Expected results:
the lun should use a new connection with the new password.

Comment 2 Elad 2015-06-14 07:16:15 UTC
Cannot add a direct LUN via REST due to bug 1176402. Therefore, verification cannot be done for now.

Comment 3 Allon Mureinik 2015-06-14 08:29:43 UTC
(In reply to Elad from comment #2)
> Cannot add a direct LUN via REST due to bug 1176402. Therefore, verification
> cannot be done for now.

I'm guessing this is a copy-paste error and you meant bug 1220824?
(if so, note that this is already merged, and will be available to QE in the next build, so head's up)

Comment 4 Elad 2015-06-14 08:35:03 UTC
(In reply to Allon Mureinik from comment #3)
> I'm guessing this is a copy-paste error and you meant bug 1220824?
Yes :)
> (if so, note that this is already merged, and will be available to QE in the
> next build, so head's up)

Comment 5 Elad 2015-09-24 10:29:13 UTC
A new connection with the right credentials is being added to the storage_server_connections table when adding a second LUN with the right credentials to the system while a connection with the wrong credentials already exists in the DB.
The new LUN that is being added is using the new storage connection.

Verified using rhevm-3.6.0-0.16.master.el6.noarch

Comment 6 Allon Mureinik 2016-03-10 10:42:56 UTC
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE

Comment 7 Allon Mureinik 2016-03-10 10:47:25 UTC
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE

Comment 8 Allon Mureinik 2016-03-10 12:03:57 UTC
RHEV 3.6.0 has been released, setting status to CLOSED CURRENTRELEASE


Note You need to log in before you can comment on or make changes to this bug.