Bug 1176406 - Connecting to IPv6 RDP hosts doesn't work in Remmina
Summary: Connecting to IPv6 RDP hosts doesn't work in Remmina
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: remmina
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-21 13:03 UTC by Jeremy Visser
Modified: 2015-07-08 22:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-24 20:42:54 UTC
Type: Bug
jeremy: needinfo-


Attachments (Terms of Use)

Description Jeremy Visser 2014-12-21 13:03:54 UTC
Description of problem:

When attempting to connect to IPv6 RDP hosts, the message "Unable to connect to RDP server <hostname>" is received, whether via a raw IP address (2001:db8::1) or hostname (rdp.foocorp.local).

Version-Release number of selected component (if applicable):

remmina-1.1.1-1.git.efb7b5f.fc21.x86_64
remmina-plugins-rdp-1.1.1-1.git.efb7b5f.fc21.x86_64
freerdp-libs-1.2.0-0.2.beta.1.fc21.x86_64


How reproducible:

Easily reproducible on an up-to-date Fedora 21.

Steps to Reproduce:
1. Install Remmina and RDP plugin
2. Attempt to connect to an IPv6-only RDP host (either by IP address or hostname)
3. Observe error message

Additional info:

Previously on Fedora 20 connecting via hostname or IP address worked perfectly.  This is a regression since Fedora 21.

When attempting to connect via hostname, only an A record is looked up.  Remmina doesn't appear to even attempt to look up an AAAA record.

Comment 1 Jeremy Visser 2015-02-03 03:57:32 UTC
For the record, using the latest Remmina 'next' branch with the latest FreeRDP 'master' branch from upstream git, this bug is fixed, and connecting to IPv6 hosts works perfectly.

Comment 2 Pavel Alexeev 2015-03-16 20:49:47 UTC
Thank you for the bugreport and willing make free software better.
It seems reported upstream: https://github.com/FreeRDP/Remmina/issues/170
Please try newer version 1.1.2. Does it solve problem?

Comment 3 Jeremy Visser 2015-03-17 03:17:29 UTC
Hi Pavel,

I am running remmina-1.1.2-1.fc21.x86_64 and I can confirm the issue still exists in that release.

Cheers,
Jeremy.

Comment 4 Pavel Alexeev 2015-03-24 20:42:54 UTC
Thank you for the bugreport and willing make free software better.

Issue reported to upstream authors: https://github.com/FreeRDP/Remmina/issues/528

I continue watch upstream issue. And when it will be fixed I plan update remmina (or patch) in Fedora.

Untill no it reported and I going close it.

Comment 5 Pavel Alexeev 2015-07-08 20:29:21 UTC
Jeremy could you please test:
So the user should test as well with xfreerdp /v:[ipv6_adress] or /v:dnsnamethatresolvestov6
?

Comment 6 Jeremy Visser 2015-07-08 22:37:29 UTC
Sorry, I no longer have time to provide feedback on this bug.


Note You need to log in before you can comment on or make changes to this bug.