Bug 1176457 - Can not restore backup file to rhevm with non-default lc_messages
Summary: Can not restore backup file to rhevm with non-default lc_messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Yedidyah Bar David
QA Contact: Jiri Belka
URL:
Whiteboard:
Depends On:
Blocks: 1078871 1192954
TreeView+ depends on / blocked
 
Reported: 2014-12-22 00:56 UTC by Yoshinori Takahashi
Modified: 2019-04-28 10:46 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, lc_messages was sometimes set to a non-English locale in postgresql.conf. As a result, engine-backup --mode=restore did not filter expected errors, which are in English, and failed. To fix this, engine-backup --mode=restore was changed to require lc_messages to be en_US.UTF-8, and engine-setup was changed to set lc_messages to en_US.UTF-8 on clean installs, and require that on upgrades (and abort otherwise). Now, if lc_messages is not en_US.UTF-8, engine-backup --mode=restore exits with a more helpful error message. engine-setup sets it correctly on clean installs even if the system locale is different, and aborts on upgrades if it is not set correctly.
Clone Of:
: 1192954 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:53:18 UTC
oVirt Team: Integration
Target Upstream Version:
ylavi: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 37193 master ABANDONED packaging: engine-backup: filter errors by codes Never
oVirt gerrit 37806 master MERGED packaging: setup: pg conf check/set lc_messages Never
oVirt gerrit 37809 master MERGED packaging: engine-backup: Require lc_messages = en_US.UTF-8 Never
oVirt gerrit 37811 ovirt-engine-3.5 ABANDONED packaging: setup: pg conf check/set lc_messages Never
oVirt gerrit 37812 ovirt-engine-3.5 MERGED packaging: engine-backup: Require lc_messages = en_US.UTF-8 Never
oVirt gerrit 37814 master MERGED packaging: setup: Fix check of pg conf Never
oVirt gerrit 37815 ovirt-engine-3.5 ABANDONED packaging: setup: Fix check of pg conf Never
oVirt gerrit 37828 master MERGED packaging: setup: Move provisioning init to common Never
oVirt gerrit 37870 master MERGED packaging: setup: clean up db connection plugins Never
Red Hat Knowledge Base (Solution) 2138121 None None None 2016-01-25 10:33:13 UTC

Comment 5 Sandro Bonazzola 2015-01-09 14:11:49 UTC
Initially targeting to 3.6 while the issue will be investigated.

Comment 6 Yedidyah Bar David 2015-01-21 13:54:56 UTC
Seems like the problem is due to a locale in which 'Language "plpgsql" already exists' is translated - still didn't reproduce.

Comment 9 Yedidyah Bar David 2015-01-25 10:53:47 UTC
We have some technical difficulties working with lc_messages set to some non-en-US locale. In this bug, about engine-backup, which uses psql to restore, we found some workaround, but we want to apply the same logic in engine-setup (see bug 1078871), which uses pg_restore, where a similar workaround does not seem possible.

How important it is to support foreign locales? Will it be an acceptable solution if our tools (engine-setup, engine-backup) support only en_US.UTF-8, check this early and abort otherwise?

BTW, please verify that this indeed is the problem - if so, the following should be a workaround:

Edit /var/lib/pgsql/data/postgresql.conf
Find lc_messages, it should probably be:
lc_messages = 'ja_JP.UTF-8'
Change this line to be:
lc_messages = 'en_US.UTF-8'
Then restart postgresql (you might need to stop connected clients, including the engine, dwhd).

Comment 15 Jiri Belka 2015-04-16 14:44:34 UTC
ok, ovirt-engine-setup-3.6.0-0.0.master.20150412172306.git55ba764.el6.noarch

works exactly as described in #11

Comment 16 Nicolas Ecarnot 2015-12-30 13:11:33 UTC
(In reply to Yedidyah Bar David from comment #9)
> How important it is to support foreign locales?

Though I'm french, I very often prefer getting English reports, messages and log files. Moreover, if it could break anything, please choose English.

> BTW, please verify that this indeed is the problem - if so, the following
> should be a workaround

Working workaround.

Comment 17 Yedidyah Bar David 2015-12-30 13:18:47 UTC
(In reply to Nicolas Ecarnot from comment #16)
> (In reply to Yedidyah Bar David from comment #9)
> > How important it is to support foreign locales?
> 
> Though I'm french, I very often prefer getting English reports, messages and
> log files. Moreover, if it could break anything, please choose English.
> 
> > BTW, please verify that this indeed is the problem - if so, the following
> > should be a workaround
> 
> Working workaround.

Thanks for the report!

Comment 20 errata-xmlrpc 2016-03-09 20:53:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.