Bug 117651 - quality is miserable - flickering horizontal and vertical lines
quality is miserable - flickering horizontal and vertical lines
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tvtime (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-06 06:11 EST by shrek-m
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.9.12-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-29 16:09:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cat_watch.txt (3.48 KB, text/plain)
2004-03-08 15:56 EST, shrek-m
no flags Details

  None (edit)
Description shrek-m 2004-03-06 06:11:32 EST
Description of problem:
tvtime has a miserable image quality vs xawtv on the same machine.

xawtv from fc1 or knoppix 3.2 has an excellent image quality
source:
digital-sat-receiver -> scart-svideo composite1 -> bt878

i was playing several times and hours with tvtime to get an acceptable
result since fc2t1 came out, no luck.

the best results i could get:

- bad image quality
- sometimes slow (evtl fc2t1=debug-mode)
- depending on the window-size
(little = more lines, great = less lines)
horizontal and vertical flickering lines in the right and top borders
   -----+
   ----||
       ||
       |+

i think that both could coexist very well.
solution:
a; tvtime and xawtv, both in fc2
b: make tvtime work properly

Version-Release number of selected component (if applicable):
tvtime-0.9.12-3 and earlier

How reproducible:
Always

Steps to Reproduce:
1. start tvtime
2. play with the settings to get an acceptable result
3. boot in fc1 or knoppix and start xawtv
    

Actual Results:  cry out loud: "bring back xawtv in fc2"

Expected Results:  tvtime should have the same quality like xawtv

Additional info:

# rpm -q kernel tvtime
kernel-2.6.1-1.65
kernel-2.6.3-1.118
tvtime-0.9.12-3

# lspci | grep -i bt
0000:00:0f.0 Multimedia video controller: Brooktree Corporation Bt878
Video Capture (rev 02)
0000:00:0f.1 Multimedia controller: Brooktree Corporation Bt878 Audio
Capture (rev 02)


# lsmod | grep bttv
bttv                  149740  1
video_buf              21252  1 bttv
i2c_algo_bit            8200  1 bttv
v4l2_common             6272  1 bttv
btcx_risc               4616  1 bttv
i2c_core               21380  4 tuner,tvaudio,bttv,i2c_algo_bit
videodev                9472  2 bttv
Comment 1 shrek-m 2004-03-07 03:21:39 EST
xawtv download
Latest version 3.91, released 29 Jan 2004.

http://bytesex.org/xawtv/

./configure;make;make install
directly comparison with tvtime under fc2t1

outsch!
urgent!
please bring back XAWTV in FC2

with xawtv out of the box:
2 clicks (select composite 1) and i have
  absolutely sharp images
  clear colors
  clear letters
  no flickering lines


with tvtime:
i have no need for an digital-sat-receiver,
i could switch back to an terristric antenna hanging in the wind,
it is so slow and such a bad quality  :-(
Comment 2 shrek-m 2004-03-08 15:55:42 EST
tv-standard PAL
i686, 400 mhz, 265 mb ram
$ /sbin/lspci | grep -i bt
0000:00:0f.0 Multimedia video controller: Brooktree Corporation Bt878
Video Capture (rev 02)
0000:00:0f.1 Multimedia controller: Brooktree Corporation Bt878 Audio
Capture (rev 02)

see the attachment
$ watch -n10 "ps up 21905 >>tvtime-watch"
$ watch -n10 "ps up 21835 >>xawtv-watch"
Comment 3 shrek-m 2004-03-08 15:56:12 EST
Created attachment 98381 [details]
cat_watch.txt
Comment 4 Ellen Shull 2004-03-08 21:26:11 EST
I agree that FC2 should include both xawtv and tvtime. 
 
There are several reasons why Shrek may be getting suboptimal 
performance out of tvtime.  The reason tvtime looks so good (when 
the system can handle it) is that it can apply some very nice 
deinterlacing algorithms to the video before displaying it.  This 
leads to a big tree of performance dependencies: 
 
-> it has to run in capture mode instead of overlay mode (tvtime 
does not support overlay mode at all) 
   -> greater I/O load since all the data is going through the CPU 
      -> your card and driver have to support and use DMA or you're 
not going be able to get reasonable framerates at any resolution (a 
common failure mode is like what you're seeing; the CPU hasn't 
finished copying one frame before it's time for the next, so you get 
"tearing" where the image becomes the next frame, or just garbage) 
-> greater CPU load from 
   -> postprocessing (depends on which deinterlacing mode you have 
selected) 
   -> video output (especially if your display card/driver doesn't 
support Xv) 
 
From the ultra-low cpu utilization in Shrek's xawtv ps, I'm guessing 
he's running xawtv in overlay mode? 
Comment 5 shrek-m 2004-04-29 16:09:16 EDT
seems to be solved in fc2t3
clean, fresh install on the same box.
400 mhz 256 mb ram

tvtime is a bit slow but no flickering lines

input video source: composite1
tv-standard: PAL

tvtime-0.9.12-5
kernel-2.6.5-1.327
Comment 6 Billy Biggs 2004-06-22 08:42:06 EDT
Hi, I am the author of tvtime.

Usually if you see 'flickery lines', this is caused because of
bandwidth problems over your bus, probably because you are using a PCI
video card.  If you are having performance problems with tvtime,
please contact me at vektor@dumbterm.net so I can try to debug it with
you.

Note You need to log in before you can comment on or make changes to this bug.