Bug 117670 - gstreamer-properties doesn't do anything
Summary: gstreamer-properties doesn't do anything
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-media   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-03-06 21:16 UTC by John Thacker
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 07:21:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hack to make it work with gstreamer 0.7.5 and up (1.28 KB, patch)
2004-03-06 21:17 UTC, John Thacker
no flags Details | Diff

Description John Thacker 2004-03-06 21:16:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
See upstream bug http://bugzilla.gnome.org/show_bug.cgi?id=136406

GStreamer, starting right before the 0.7.5 release, changed the
location of the gconf keys for GStreamer, adding versioning so that
multiple versions of the runtime libraries could be installed at once
with different settings.

/system/gstreamer/default/audiosink ->
/system/gstreamer/default/0.7/audiosink

and so on.
Unfortunately, gstreamer-properties, in the gnome-media package,
hardcodes in the location of the GConf keys, rather than using the API
provided with GStreamer.  As a result, gstreamer-properties doesn't
actually change any settings with gstreamer 0.7.5 and up, since it
changes the wrong GConf keys.

The right way to solve this is to change gstreamer-properties to use
GStreamer's API.  A quick hack is possible, by changing the hardcoded
values, although this won't work with gstreamer before 0.7.5, and will
have to be changed when GStreamer moves to 0.8.0

In summary, with current Rawhide, gstreamer-properties doesn't do
anything.  gstreamer's defaults can still be changed with
gconf-editor, but that's really not recommended for average users.

Version-Release number of selected component (if applicable):
gnome-media-2.5.4-2

How reproducible:
Always

Steps to Reproduce:
1. gstreamer-properties
2. try to change a setting
    

Actual Results:  No effect on GStreamer defaults.

Expected Results:  Changing a setting affects the GStreamer defaults.

Additional info:

Comment 1 John Thacker 2004-03-06 21:17:40 UTC
Created attachment 98347 [details]
Hack to make it work with gstreamer 0.7.5 and up

Comment 2 John Thacker 2004-03-11 07:21:28 UTC
Fixed upstream in gnome-media-2.5.5, and thus it will make it in to
FC2 before release.


Note You need to log in before you can comment on or make changes to this bug.