This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 117672 - Please avoid trailing newlines in authconfig messages
Please avoid trailing newlines in authconfig messages
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
http://developer.gnome.org/doc/tutori...
: StringChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-06 16:54 EST by Christian Rose
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-17 10:07:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2004-03-06 16:54:03 EST
#: authconfig.c:881
msgid "disable MD5 passwords by default\n"

#: authconfig.c:890
msgid "default NIS server\n"

#: authconfig.c:907
msgid "default LDAP base DN\n"

#: authconfig.c:918
msgid "default kerberos realm\n"

#: authconfig.c:927
msgid "disable use of DNS to find kerberos realms\n"

#: authconfig.c:936
msgid "names of servers to authenticate against\n"

#: authconfig.c:979
msgid "join the winbind domain or ads realm now as this administrator\n"

#: authconfig.c:985
msgid "disable wins for hostname resolution\n"

#: authconfig.c:994
msgid "default hesiod RHS\n"

#: authconfig.c:999
msgid "disable caching of user information by default\n"

#: authconfig.c:1026
#, c-format
msgid "%s: bad argument %s: %s\n"

#: authconfig.c:1035
#, c-format
msgid "%s: attempting to continue\n"

#: authconfig.c:1039
#, c-format
msgid "%s: unexpected argument\n"

#: authconfig.c:1071
#, c-format
msgid "%s: can only be run as root\n"

#: authconfig.c:1247
msgid "dialog was cancelled\n"


Trailing newlines is a plague for translators (see
http://developer.gnome.org/doc/tutorials/gnome-i18n/developer.html#language).
Also, it makes the messages in authconfig inconsistent with eachother
as most messages don't use trailing newlines.
Comment 1 Jindrich Novy 2004-09-02 07:28:51 EDT
Hello Christian, trailing newlines will be eliminated from l10n
strings starting from authconfig-4.6.5.

Jindrich
Comment 2 Christian Rose 2004-09-02 15:00:23 EDT
Why did you mark this as NOTABUG? This is sure a problem for translators.
Comment 3 Jindrich Novy 2004-09-03 03:46:25 EDT
I closed this bug as NOTABUG, because it is reported with "normal"
severity, where it is not a bug. I think that it is not a bug, because
it doesn't affect functionality of authconfig. (please use
"translation" severity for such reports)

Jindrich
Comment 4 Christian Rose 2004-12-30 10:51:57 EST
D'oh -- you could just have marked it with "translation" severity
yourself.
Comment 5 Tomas Mraz 2005-01-17 10:07:16 EST
This won't be fixed. The messages are already translated, removing the
newlines would create even more mess.
Comment 6 Christian Rose 2005-01-17 14:26:45 EST
If authconfig is deprecated software that will never have any new
releases or translations from now on, I'm bound to agree.

If not, then I don't think the answer "changing now would be more
problematic" is a given fact. That would imply that you don't expect
authconfig to receive new translations. It also leaves the question
unanswered if you intend to avoid newlines on new messages, and if not
why. If so, I see a consistency problem coming, where some messages
may be duplicated, one in an older version with trailing newline, and
one without.
Comment 7 Tomas Mraz 2005-01-18 09:06:56 EST
No, it isn't deprecated. I'll try to avoid such trailing \n in new
messages but of course I won't create duplicate messages.
But I don't see it as too big problem for translators if there aren't
such duplicates.

Note You need to log in before you can comment on or make changes to this bug.