Bug 117683 - plugins are in /usr/lib64/gstreamer-0.6, gstreamer looks for them in /usr/lib/gstreamer-0.6
plugins are in /usr/lib64/gstreamer-0.6, gstreamer looks for them in /usr/lib...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-06 22:07 EST by Nicholas Miell
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-06 19:46:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
quick fix (728 bytes, patch)
2004-03-06 22:09 EST, Nicholas Miell
no flags Details | Diff

  None (edit)
Description Nicholas Miell 2004-03-06 22:07:43 EST
gstreamer hardcodes the plugin path to /usr/lib/gstreamer-0.6, which
means it can't find any of it's plugins on a fresh FC1-x86_64 install.
Comment 1 Nicholas Miell 2004-03-06 22:09:52 EST
Created attachment 98351 [details]
quick fix

I know nothing about autoconf, so this patch is broken for the general case.

However, for a rpmbuild, it fixes the defintion of PLUGIN_PATH so that
gstreamer can actually work.
Comment 2 Colin Walters 2004-04-06 19:46:19 EDT
This appears to have been resolved upstream in GStreamer, please
reopen if you can still reproduce.

Note You need to log in before you can comment on or make changes to this bug.