Bug 117696 - sysklogd segfault as built with -pie
sysklogd segfault as built with -pie
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: sysklogd (Show other bugs)
1.0
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-07 06:51 EST by Paul Nasrat
Modified: 2014-03-16 22:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-08 11:39:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Nasrat 2004-03-07 06:51:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
sysklogd segfaulting on ppc probably due to gcc bug with -pie which
seems to be fixed.

Rebuild against rawhide (gcc-3.3.3-2) works as expected.

See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=115014

Could this be rebuilt?

Version-Release number of selected component (if applicable):
sysklogd-1.4.1-13.1

How reproducible:
Always

Steps to Reproduce:
1. upgrade to rawhide on ppc
2. run syslog

    

Actual Results:  Segmentation fault

Expected Results:  Works happily

Additional info:
Comment 1 Bill Nottingham 2004-03-08 11:39:21 EST
Rebuilt as -14.

Note You need to log in before you can comment on or make changes to this bug.