Bug 117697 - cifs mount dies while transfering files
cifs mount dies while transfering files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-07 09:55 EST by Matthew Sutton
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 09:43:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Sutton 2004-03-07 09:55:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
After I mount a cifs share that is on a windows 2000 machine, I begin 
to copy a large amount of files from the mount to the local drive for 
backup purposes.  The cifs share begins to get "cannot stat <mount> 
Input/Output error".  And then the file transfer dies.  If I unmount 
then remount the share, I can then get a directory listing but the 
file transfer still does not work.   

Version-Release number of selected component (if applicable):
kernel-2.6.3-2.1.240 
samba-3.0.2a-1

How reproducible:
Always

Steps to Reproduce:
1. mount a cifs share
2. begin to copy files
3.     

Actual Results:  cannot stat <mount> Input/Output error

Expected Results:  be able to copy files from a cifs mount to local 
drive without errors, and without having to reboot to finish 
transfers.

Additional info:

This has been happening since the first test 1 kernel came out.

my /var/log/messages is filled with these two lines over and over

kernel:  CIFS VFS: Error 0xfffffffb or (-5 decimal) on 
cifs_get_inode_info in lookup
kernel:  CIFS VFS: Need to reconnect after session died to server
Comment 1 Dave Jones 2004-06-14 19:56:40 EDT
How do things look with the current update kernel ?
There have been a boatload of CIFS fixes since 2.6.3
Comment 2 Matthew Sutton 2004-06-15 08:11:12 EDT
Things are going great now.  I currently am pulling backups from a 
windows 2003 server and cifs is solid.

Note You need to log in before you can comment on or make changes to this bug.