Bug 1176987 - unrtf-0.21.9 is available
Summary: unrtf-0.21.9 is available
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: unrtf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ken Dreyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-23 16:57 UTC by Upstream Release Monitoring
Modified: 2015-01-24 18:51 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-01-04 03:53:36 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Savannah 43914 None None None Never
GNU Savannah 43929 None None None Never

Description Upstream Release Monitoring 2014-12-23 16:57:25 UTC
Latest upstream release: 0.21.8
Current version/release in Fedora Rawhide: 0.21.7-1.fc22
URL: http://ftp.gnu.org/gnu/unrtf/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring Soon this service will be implemented by a new system: https://release-monitoring.org/
It will require to manage monitored projects via a new web interface. Please make yourself familiar with the new system to ease the transition.

Comment 1 Ken Dreyer 2015-01-02 14:25:34 UTC
There are some issues with the "./config" directory in the source tree of this release. We need to BR: automake, and there's also a regression with "make check": https://savannah.gnu.org/bugs/index.php?43914

Comment 2 Upstream Release Monitoring 2015-01-04 01:51:27 UTC
Latest upstream release: 0.21.9
Current version/release in Fedora Rawhide: 0.21.7-1.fc22
URL: http://ftp.gnu.org/gnu/unrtf/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring Soon this service will be implemented by a new system: https://release-monitoring.org/
It will require to manage monitored projects via a new web interface. Please make yourself familiar with the new system to ease the transition.

Comment 3 Ken Dreyer 2015-01-04 03:53:36 UTC
The 0.21.9 tarball contains the missing test-driver file I mentioned in comment #1, so that's good.

However, since upstream has switched to using symlinks in ./config/, and these symlinks depend on a particular path to automake-1.13's files, the build breaks on Fedora where we ship a newer automake (v1.14). I wonder if the upstream author has run automake without the "-c" flag (ie, running automake by hand, instead of running ./bootstrap).

I've reported this upstream at https://savannah.gnu.org/bugs/index.php?43929

In the mean time, for Fedora the solution is to run ./bootstrap during the RPM %build in order to regenerate the automake/autoconf files. This allows the build to succeed on both automake 1.13 and 1.14.

0.21.9 committed to dist-git: http://pkgs.fedoraproject.org/cgit/unrtf.git/commit/?id=899df8fcbd36e5ce726327b5541e1b9011aba175

Rawhide (F22) build: http://koji.fedoraproject.org/koji/taskinfo?taskID=8520411

Comment 4 Fedora Update System 2015-01-04 04:01:31 UTC
unrtf-0.21.9-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/unrtf-0.21.9-1.fc21

Comment 5 Fedora Update System 2015-01-04 04:02:29 UTC
unrtf-0.21.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/unrtf-0.21.9-1.fc19

Comment 6 Fedora Update System 2015-01-04 04:03:35 UTC
unrtf-0.21.9-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/unrtf-0.21.9-1.el7

Comment 7 Fedora Update System 2015-01-04 04:04:17 UTC
unrtf-0.21.9-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/unrtf-0.21.9-1.el6

Comment 8 Fedora Update System 2015-01-04 15:33:51 UTC
unrtf-0.21.9-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/unrtf-0.21.9-1.fc20

Comment 9 Fedora Update System 2015-01-13 00:03:17 UTC
unrtf-0.21.9-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-01-13 00:06:17 UTC
unrtf-0.21.9-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-01-24 18:51:43 UTC
unrtf-0.21.9-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-01-24 18:51:59 UTC
unrtf-0.21.9-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.