Bug 1177052 - Basemap cannot find data files
Summary: Basemap cannot find data files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-basemap
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1177319 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-24 00:25 UTC by Elliott Sales de Andrade
Modified: 2015-03-20 10:45 UTC (History)
4 users (show)

Fixed In Version: python-basemap-1.0.7-6.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-03 12:06:27 UTC


Attachments (Terms of Use)

Description Elliott Sales de Andrade 2014-12-24 00:25:33 UTC
Description of problem:
Importing basemap fails because it can't find its plotting data.

Version-Release number of selected component (if applicable):
python-basemap-1.0.7-4.fc21.x86_64
python-basemap-data-1.0.7-2.fc21.noarch


Actual results:

$ python -c 'from mpl_toolkits.basemap import Basemap'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/mpl_toolkits/basemap/__init__.py", line 30, in <module>
    from mpl_toolkits.basemap import pyproj
  File "/usr/lib64/python2.7/site-packages/mpl_toolkits/basemap/pyproj.py", line 241, in <module>
    raise IOError(msg)
IOError: proj data directory not found. Expecting it at: /usr/lib64/python2.7/site-packages/mpl_toolkits/basemap/data

$ python3 -c 'from mpl_toolkits.basemap import Basemap'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib64/python3.4/site-packages/mpl_toolkits/basemap/__init__.py", line 30, in <module>
    from mpl_toolkits.basemap import pyproj
  File "/usr/lib64/python3.4/site-packages/mpl_toolkits/basemap/pyproj.py", line 241, in <module>
    raise IOError(msg)
OSError: proj data directory not found. Expecting it at: /usr/lib64/python3.4/site-packages/mpl_toolkits/basemap/data

Expected results:
Example commands run without error.

Comment 1 Fedora Update System 2015-01-15 15:59:43 UTC
python-basemap-1.0.7-6.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-basemap-1.0.7-6.fc21

Comment 2 Fedora Update System 2015-01-15 16:00:53 UTC
python-basemap-1.0.7-6.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/python-basemap-1.0.7-6.el7

Comment 3 lnie 2015-01-16 08:43:03 UTC
python-basemap-1.0.7-6.fc21 works

Comment 4 Fedora Update System 2015-01-16 19:11:10 UTC
Package python-basemap-1.0.7-6.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python-basemap-1.0.7-6.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-0320/python-basemap-1.0.7-6.el7
then log in and leave karma (feedback).

Comment 5 Elliott Sales de Andrade 2015-01-18 06:13:06 UTC
Works for me.

PS, don't forget to mark bug 1177903 as a dupe.

Comment 6 Fedora Update System 2015-02-03 12:06:27 UTC
python-basemap-1.0.7-6.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2015-02-03 19:31:14 UTC
python-basemap-1.0.7-6.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Jos de Kloe 2015-03-20 10:45:47 UTC
*** Bug 1177319 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.