Bug 117710 - sched.c gives calltrace when lp0 runs out of paper
sched.c gives calltrace when lp0 runs out of paper
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-07 15:50 EST by Eric N. Ebert
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-10 21:55:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric N. Ebert 2004-03-07 15:50:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040217 Epiphany/1.1.10

Description of problem:
I tried to reproduce this but couldn't. It occured eight times and
then when I tried to reproduce it I couldn't. The error message that
appeared in /var/log/messages is below.



Version-Release number of selected component (if applicable):
kernel-2.6.3-2.1.242smp

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1.Start printing a document
2.Printer runs out of paper in middle of print job
3.Call trace appears in /var/log/messages
    

Actual Results:  Message appeared in /var/log/messages

Expected Results:  For sched.c not to fault

Additional info:

lp0 out of paper
Badness in interruptible_sleep_on_timeout at kernel/sched.c:1938
xwing kernel: Call Trace:
xwing kernel:  [<0212417e>] interruptible_sleep_on_timeout+0x5d/0x154
xwing kernel:  [<02123c08>] default_wake_function+0x0/0xc
xwing kernel:  [<46d6d10c>] lp_error+0x40/0x81 [lp]
xwing kernel:  [<46d6d1f0>] lp_check_status+0xa3/0xaa [lp]
xwing kernel:  [<46d6d21e>] lp_wait_ready+0x27/0x59 [lp]
xwing kernel:  [<46d6d3d7>] lp_write+0x187/0x2a6 [lp]
xwing kernel:  [<02161bad>] vfs_write+0xb8/0xe4
xwing kernel:  [<02161c47>] sys_write+0x2c/0x42
Comment 1 Arjan van de Ven 2004-03-08 06:34:31 EST
ok bug found; fixed for the next build

Note You need to log in before you can comment on or make changes to this bug.