Bug 1177131 - capslock does not perform shift and key combination
Summary: capslock does not perform shift and key combination
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.1
Hardware: All
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1187010 (view as bug list)
Depends On:
Blocks: 1188012
TreeView+ depends on / blocked
 
Reported: 2014-12-24 10:40 UTC by Xu Han
Modified: 2015-12-04 16:24 UTC (History)
12 users (show)

Fixed In Version: qemu 2.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:24:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 121451 None None None Never
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Xu Han 2014-12-24 10:40:59 UTC
Description of problem:
Capslock does not perform shift and key combination, just got character '\'(keycode 43) from guest.

Have tested two scenarios.
Step: (qemu) sendkey caps_lock-a
Result:
+--------------+----+
| SLOF cmdline | A  |
+--------------+----+
| RHEL shell   | \a |
+--------------+----+

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.1.2-16.el7.ppc64
SLOF-20140630-2.gitf284ab3.el7.noarch
kernel-3.10.0-217.ael7a.ppc64le(guest)

How reproducible:
100%

Steps to Reproduce:
1. Boot guest
2. (qemu) sendkey caps_lock-a

Actual results:
Got '\a'

Expected results:
Get 'A'

Additional info:
# showkey -k
(qemu) sendkey caps_lock

Result:
kb mode was UNICODE
[ if you are trying this under X, it might not work
since the X server is also reading /dev/console ]

press any key (program terminates 10s after last keypress)...
keycode  43 press
keycode  43 release

Comment 2 Xu Han 2014-12-24 11:04:40 UTC
QEMU cmdline:
/usr/libexec/qemu-kvm \
    -name migrate-install-test-xuhan \
    -machine pseries,accel=kvm,usb=off \
    -m 32768 \
    -realtime mlock=off \
    -cpu POWER8 \
    -smp 20,sockets=2,cores=10,threads=1 \
    -numa node,mem=16384,cpus=0-9,nodeid=0 \
    -numa node,mem=16384,cpus=10-19,nodeid=1 \
    -uuid 5125cf27-4b01-4493-b46d-734d08becc6b \
    -no-user-config \
    -nodefaults \
    -chardev socket,id=charmonitor,path=monitor,server,nowait \
    -mon chardev=charmonitor,id=monitor,mode=control \
    -rtc base=utc \
    -boot strict=on \
    -device pci-ohci,id=usb,bus=pci.0,addr=0x1 \
    -device spapr-vscsi,id=scsi0,reg=0x2000 \
    -drive file=/home/mnt/xuhan/nfs/install-test.qcow2,if=none,id=drive-scsi0-0-0-0,format=qcow2 \
    -device scsi-hd,bus=scsi0.0,channel=0,scsi-id=0,lun=0,drive=drive-scsi0-0-0-0,id=scsi0-0-0-0,bootindex=1 \
    -netdev tap,id=hostnet0,script=/etc/qemu-ifup,downscript=/etc/qemu-ifdown,ifname=vnetmig \
    -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:5d:c7:9e,bus=pci.0,addr=0x2 \
    -chardev socket,id=charserial0,path=serial,server,nowait \
    -device spapr-vty,chardev=charserial0,reg=0x30000000 \
    -device usb-kbd,id=input0 \
    -device usb-mouse,id=input1 \
    -vnc 0.0.0.0:50 \
    -k en-us \
    -device VGA,id=video0,vgamem_mb=16,bus=pci.0,addr=0x3 \
    -global spapr-nvram.reg=0x3000 \
    -msg timestamp=on \
    -monitor stdio

Comment 5 Gu Nini 2015-01-22 11:13:49 UTC
Also found the problem on ibm power system:

Host kernel: 3.10.53-2020.1.pkvm2_1_1.49.ppc64/3.10.42-2018.1.pkvm2_1_1.46.ppc64
Guest kernel: 3.10.0-223.el7.ppc64/3.10.0-223.ael7b.ppc64le
Qemu-kvm version:
qemu-img-2.0.0-2.1.pkvm2_1_1.20.40.ppc64
qemu-kvm-2.0.0-2.1.pkvm2_1_1.20.40.ppc64
qemu-common-2.0.0-2.1.pkvm2_1_1.20.40.ppc64
qemu-system-ppc-2.0.0-2.1.pkvm2_1_1.20.40.ppc64
qemu-kvm-tools-2.0.0-2.1.pkvm2_1_1.20.40.ppc64
qemu-system-x86-2.0.0-2.1.pkvm2_1_1.20.40.ppc64
qemu-2.0.0-2.1.pkvm2_1_1.20.40.ppc64

Comment 6 Gerd Hoffmann 2015-01-22 11:43:09 UTC
http://patchwork.ozlabs.org/patch/431667/

Comment 7 mazhang 2015-01-27 06:14:28 UTC
qemu-kvm-rhev-2.1.2-22.el7.x86_64 also hit this problem.

Comment 8 IBM Bug Proxy 2015-02-06 13:20:41 UTC
------- Comment From fnovak@us.ibm.com 2015-02-06 13:13 EDT-------
reverse mirror of RHBZ 1177131 - capslock does not perform shift and key combination

Comment 10 Gerd Hoffmann 2015-04-28 05:33:55 UTC
upstream commit 0ee4de5840ccc1072459ec68062bfb63c888a94d (in qemu 2.3+)

Comment 11 Gerd Hoffmann 2015-04-29 11:06:10 UTC
patches posted.

Comment 12 Gerd Hoffmann 2015-04-30 10:20:46 UTC
*** Bug 1187010 has been marked as a duplicate of this bug. ***

Comment 13 Gerd Hoffmann 2015-04-30 15:25:05 UTC
patch not needed, rebase picked this up.

Comment 15 mazhang 2015-07-01 06:40:40 UTC
Reproduce this bug on qemu-kvm-rhev-2.1.2-16.el7.x86_64 and qemu-kvm-rhev-2.1.2-17.ael7b.ppc64le.

X86
host:
qemu-kvm-rhev-2.1.2-16.el7.x86_64
3.10.0-287.el7.x86_64
guest:
3.10.0-229.el7.x86_64

Powerpc
host:
qemu-kvm-rhev-2.1.2-17.ael7b.ppc64le
3.10.0-287.el7.ppc64le
guest:
3.10.0-229.el7.ppc64

Steps:
1. Boot guest with usb-kbd device.
eg:
-usb \
-device usb-kbd,id=input0 \

2. Send key "caps_lock-a"
(qemu) sendkey caps_lock-a

Result:
Got '\a' inside guest.


Verify this bug on qemu-kvm-rhev-2.3.0-6.el7.x86_64 and qemu-kvm-rhev-2.3.0-6.el7.ppc64le

After updated qemu-kvm-rhev package, got 'A' in guest, both x86 and power platform tested.

So this bug has been fixed.

Comment 17 errata-xmlrpc 2015-12-04 16:24:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.