Bug 1177151 - update piglit and make usable
Summary: update piglit and make usable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: piglit
Version: rawhide
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Matěj Cepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-24 14:45 UTC by Igor Gnatenko
Modified: 2018-04-11 18:53 UTC (History)
3 users (show)

Fixed In Version: piglit-1-0.21.20150103GIT4adb082.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-17 05:36:38 UTC


Attachments (Terms of Use)
ls -lR of ~/build/BUILDROOT where the package installation tree builds (1.88 MB, text/plain)
2015-01-03 20:12 UTC, Matěj Cepl
no flags Details
crash of quick test (32.67 KB, text/plain)
2015-01-03 20:24 UTC, Matěj Cepl
no flags Details

Description Igor Gnatenko 2014-12-24 14:45:22 UTC
First, we need update piglit to latest version from git.

There `cmake install` available, so please use it.

also if I'm using /usr/bin/piglit-run test/sanity.py ~/tmp
I'm getting error about libraries not found.

If we're using chrpath we should put libs to libdir and do ldconfig in %post, %postun stages.



This is very critical to get working piglit and providing service to track regressions in mesa, because now we updating mesa frequently.

Comment 1 Matěj Cepl 2015-01-03 20:12:34 UTC
Created attachment 975730 [details]
ls -lR of ~/build/BUILDROOT where the package installation tree builds

(In reply to Igor Gnatenko from comment #0)
> There `cmake install` available, so please use it.

Except (see the log) ... make install is completely broken (cmake is a tool just for generating Makefiles, you run regular make on those).

When I run

make install DESTDIR=$RPM_BUILD_ROOT

I get what's attached ... it is absolutely inappropriate to install arch-dependent material in /usr/lib/, which is exactly what those Makefiles do, because nobody thought about multilib. I'll investigate that.

Comment 2 Matěj Cepl 2015-01-03 20:24:42 UTC
Created attachment 975731 [details]
crash of quick test

Comment 3 Fedora Update System 2015-01-07 11:39:28 UTC
piglit-1-0.21.20150103GIT4adb082.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/piglit-1-0.21.20150103GIT4adb082.el7

Comment 4 Fedora Update System 2015-01-07 11:43:07 UTC
piglit-1-0.21.20150103GIT4adb082.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/piglit-1-0.21.20150103GIT4adb082.fc20

Comment 5 Fedora Update System 2015-01-07 11:43:41 UTC
piglit-1-0.21.20150103GIT4adb082.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/piglit-1-0.21.20150103GIT4adb082.fc21

Comment 6 Fedora Update System 2015-01-07 19:31:56 UTC
Package piglit-1-0.21.20150103GIT4adb082.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing piglit-1-0.21.20150103GIT4adb082.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-0145/piglit-1-0.21.20150103GIT4adb082.el7
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2015-01-17 05:36:38 UTC
piglit-1-0.21.20150103GIT4adb082.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2015-01-17 05:49:05 UTC
piglit-1-0.21.20150103GIT4adb082.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2015-01-24 18:47:19 UTC
piglit-1-0.21.20150103GIT4adb082.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.