Bug 1177242 - windows-credprov: OVirtCredProv.rc references afxres.h which does not seem to be used
Summary: windows-credprov: OVirtCredProv.rc references afxres.h which does not seem to...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-guest-agent
Classification: oVirt
Component: General   
(Show other bugs)
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: ovirt-3.6.0-rc3
: 1.0.11-3
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Jiri Belka
URL: https://raw.githubusercontent.com/oVi...
Whiteboard: virt
Keywords: CodeChange
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-25 10:22 UTC by Evgheni Dereveanchin
Modified: 2016-02-10 19:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 07:55:26 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt-3.6.0+
ylavi: planning_ack+
michal.skrivanek: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46586 master MERGED Providing afxres.h for cases where no MFC is available for VC Never
oVirt gerrit 46662 ovirt-3.6 MERGED Providing afxres.h for cases where no MFC is available for VC Never

Description Evgheni Dereveanchin 2014-12-25 10:22:32 UTC
Description of problem:
the RC file for windows-credprov references afxres.h which is part of MFC Library. This is not shipped with VS2008 Express, so it's impossible to compile the DLL with the free version. Replacing this include with windows.h removes the dependency and still produces a working DLL.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. install Visual Studio 2008 Express
2. download ovirt-guest-agent/windows-credprov from GIT
3. open ovirt-guest-agent/windows-credprov/OVirtCredProv.vcproj with VS2008 Express and try to build the project

Actual results:
Build fails with error:

fatal error RC1015: cannot open include file 'afxres.h'. from this code

Expected results:
Build succeeds on the free version of Visual Studio 2008

Additional info:
As stated above, this does not seem to be used but I am no windows developer to check or confirm this.

Comment 3 Jiri Belka 2015-11-12 08:58:17 UTC
CodeChange, visible only when building, not part of QE process.

Comment 4 Sandro Bonazzola 2015-11-27 07:55:26 UTC
Since oVirt 3.6.0 has been released, moving from verified to closed current release.


Note You need to log in before you can comment on or make changes to this bug.