Bug 1177252 - VM migration failure from rhel7.1 to rhel6.6, root cause is not displayed in audit log.
Summary: VM migration failure from rhel7.1 to rhel6.6, root cause is not displayed in ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.0.1
: ---
Assignee: Shmuel Melamud
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-25 12:16 UTC by Ilanit Stein
Modified: 2016-06-29 11:53 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-29 11:53:25 UTC
oVirt Team: Virt
michal.skrivanek: ovirt-4.0.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

Description Ilanit Stein 2014-12-25 12:16:53 UTC
Description of problem:
Please add the reason why vm migration fail, in case of inhibitted migration from rhel7.1 to rhel6.6.

Version-Release number of selected component (if applicable):
rhevm vt13.5
hosts: rhel6.6, rhel7.1 (or rhel7)

How reproducible:
100%

Actual results:
Event:
"Migration failed due to Error: Fatal error during migration (VM: <vmname>, Source: <rhel7.1 hostname>, Destination: <rhel6.6 hostname>10.35.117.20)."

Expected results:
Event should be somthing like:
"Migration failed due to Error: Migration between rhel7.x to rhel6.x is inihibitted" (VM: <vmname>, Source: <rhel7.1 hostname>, Destination: <rhel6.6 hostname>10.35.117.20)."

Comment 1 Michal Skrivanek 2014-12-26 06:49:47 UTC
That's maybe a misunderstanding of the cross cluster migration. Everything is allowed, it's not inhibited, it just fails at some point. So what you see is one of the "regular" migration failures

Comment 2 Ilanit Stein 2015-01-06 14:47:51 UTC
1. In general, if there is a migration failure, and engine has info on the root cause, it could be good if it is reflected to user in the same event, reporting on migration failed.

2. Specifically here, a migration done from rhel7.1 to rhel6.6, via REST, will fail (bug 1154631). Please consider, adding the reason of why migration failed.

Comment 3 Michal Skrivanek 2015-01-07 11:00:24 UTC
well, a proper and accurate migration failure reason is the holy grail we are looking for for a long time:-)
Again, it's not failing because we inhibit anything...we don't, hence you get a particular reason, most likely related to the exact qemu-kvm versions and VM configuration

I agree "Error: Fatal error during migration" is not descriptive, and we have an existing bug for that. Although, we don't have a solution yet. This is a recurring problem. Francesco, maybe we can do finally something more with the exitcode? At least something like "libvirt call failed" or something like that...that would be the first step to be able to pull some more relevant details from libvirt in this case

Comment 4 Francesco Romani 2015-01-12 12:26:49 UTC
Reply to Michal Skrivanek from comment #3)
> well, a proper and accurate migration failure reason is the holy grail we
> are looking for for a long time:-)
> Again, it's not failing because we inhibit anything...we don't, hence you
> get a particular reason, most likely related to the exact qemu-kvm versions
> and VM configuration
> 
> I agree "Error: Fatal error during migration" is not descriptive, and we
> have an existing bug for that. Although, we don't have a solution yet. This
> is a recurring problem. Francesco, maybe we can do finally something more
> with the exitcode? At least something like "libvirt call failed" or
> something like that...that would be the first step to be able to pull some
> more relevant details from libvirt in this case

I think yes, we could improve reporting leveraging the exitReason as you suggested, at least signaling and reporting a libvirt error. Taking the bug

Comment 5 Red Hat Bugzilla Rules Engine 2015-11-16 14:11:10 UTC
This bug is flagged for 3.6, yet the milestone is for 4.0 version, therefore the milestone has been reset.
Please set the correct milestone or add the flag.

Comment 6 Yaniv Kaul 2016-03-14 11:16:12 UTC
I'd CLOSE-WONT fix this specific issue - unless this is a general issue for improving the migration failure reason reporting.

Comment 7 Shmuel Melamud 2016-03-14 12:56:53 UTC
That's exactly how I understand this bug. Need to create mechanism of reporting detailed error messages about migration failures.

Maybe create another bug for this or at least change the bug description?

Comment 8 Sandro Bonazzola 2016-05-02 09:56:49 UTC
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.

Comment 9 Yaniv Lavi 2016-05-23 13:18:04 UTC
oVirt 4.0 beta has been released, moving to RC milestone.

Comment 10 Yaniv Lavi 2016-05-23 13:24:49 UTC
oVirt 4.0 beta has been released, moving to RC milestone.

Comment 11 Michal Skrivanek 2016-06-29 11:53:25 UTC
this is no longer relevant in 4.0 as we do not support RHEL 6 hosts in any supported cluster level


Note You need to log in before you can comment on or make changes to this bug.