Bug 1177321 - [RHEL6.6] PXE booting UEFI and IPv6 client drops to grub shell
Summary: [RHEL6.6] PXE booting UEFI and IPv6 client drops to grub shell
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: grub
Version: 6.6
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1206542
TreeView+ depends on / blocked
 
Reported: 2014-12-26 06:24 UTC by Jijesh Kalliyat
Modified: 2019-01-16 09:09 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1206542 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:44:23 UTC


Attachments (Terms of Use)
IPV6 EFI boot capture (284.04 KB, application/octet-stream)
2014-12-26 06:24 UTC, Jijesh Kalliyat
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1426 normal SHIPPED_LIVE grub bug fix update 2015-07-20 18:06:18 UTC

Description Jijesh Kalliyat 2014-12-26 06:24:29 UTC
Created attachment 973136 [details]
IPV6 EFI boot capture

Description of problem:

PXE booting a client configured for UEFI and IPv6, the client drops to the grub2 shell instead of displaying the expected selection menu as configured in efidefault . Same issue is reported in RHEL7 as well, https://bugzilla.redhat.com/show_bug.cgi?id=1154226

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 6.6 

How reproducible:
Always

Steps to Reproduce:
1. Configuring a PXE Server for UEFI-based Clients, configure a RHEL server to host TFTP and DHCPv6.
2. Copy the EFI boot image, efidefault from <disc>/EFI/BOOT/* to tftp root directory.
3. Copy vmlinuz and initrd from <disc>/images/pxeboot to tftp root directory.

tree /var/lib/tftpboot/
/var/lib/tftpboot/
|-- BOOTX64.efi
|-- efidefault
|-- initrd.img
|-- splash.xpm.gz
`-- vmlinuz


4. Configure dhcpd6 ( dhcpd6.conf file ) 

subnet6  2001:1b71:83a7:1294::/64 {
         range6 2001:1b71:83a7:1294:10:61:252:25  2001:1b71:83a7:1294:10:61:252:26;
         range6 2001:1b71:83a7:1294:: temporary;
	 prefix6 2001:1b70:82a7:1259:: 2001:1b71:83a7:1294:: /64;
	 option dhcp6.bootfile-url "tftp://[2001:1b71:83a7:1294:10:61:252:17]/BOOTX64.efi";
	 option dhcp6.name-servers 2001:1b71:83a7:1294:10:61:252:17;
}

5. Configure tftp and enable ipv6 

service tftp
{
	socket_type		= dgram
	protocol		= udp
	wait			= yes
	user			= root
	server			= /usr/sbin/in.tftpd
	server_args		= -s /var/lib/tftpboot
	disable			= no
	per_source		= 11
	cps			= 100 2
	flags			= IPv6
}

6. efidefault 

#debug --graphics
default=0
splashimage=(nd)/splash.xpm.gz
timeout 5
hiddenmenu
title Red Hat Enterprise Linux 6.6
	root (nd)
	kernel /vmlinuz
	initrd /initrd.img

7. Configure client to boot in UEFI mode, and select network boot for IPv6 

Actual results: 
Client obtains IPv6 address from expected DHCP, and downloads the expected netboot image (BOOTX64.efi).  After 1-2 minutes, the client drops to the grub2 shell. The client never displays the contents of efidefault

Expected results:
PXE boot client and reach the OS selection menu as configured in efidefault

Additional info:
1. Same issue is reported in RHEL7 https://bugzilla.redhat.com/show_bug.cgi?id=1154226
2. tcpdump (ipv6-efi.pcap) shows the client pull BOOTX64.efi , but no attempt to fetch efidefault. 
3. If I disable DHCPv6 and enable DHCPv4, PXE booting in UEFI + IPv4 mode works with these clients.

Client Hardware details :-

Lenovo x230 
UFI Bios version : G2ET92WW ( 2.52 )

Comment 26 Jijesh Kalliyat 2015-03-03 06:18:07 UTC
Created attachment 997348 [details]
Grub screenshot while booting with grub-0.97-94.el6_6.x86_64.rpm

Comment 74 Jan Grulich 2015-04-07 12:00:21 UTC
Should be fixed in grub-0.97-94.el6.

Comment 76 Pavel Holica 2015-04-28 08:13:21 UTC
Verified fix on RHEL-6.7-20150415.0 x86_64 Computenode with grub-0.97-94.el6

Comment 78 errata-xmlrpc 2015-07-22 07:44:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1426.html


Note You need to log in before you can comment on or make changes to this bug.