Bug 1177330 - Search on activation_key page doesn't search the updated entity
Summary: Search on activation_key page doesn't search the updated entity
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Christine Fouant
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-26 07:05 UTC by Sachin Ghai
Modified: 2019-09-26 16:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:46:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
when you search the activation_key with updated name, search doesn't anything. However if you use old_name "test" then it filters the updated_name "mykey" (29.24 KB, image/png)
2014-12-26 07:05 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Sachin Ghai 2014-12-26 07:05:33 UTC
Created attachment 973158 [details]
when you search the activation_key with updated name, search doesn't anything. However if you use old_name "test" then it filters the updated_name "mykey"

Description of problem:
I created a activation key with name "test" and later I updated its name with "mykey".

When I go to search box to search the updated key, search doesn't show any entry. But If search with old_name("test") then it shows the updated name. 

Version-Release number of selected component (if applicable):
nightly

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.37-1.el6.noarch
* candlepin-common-1.0.17-1.el6.noarch
* candlepin-selinux-0.9.37-1.el6.noarch
* candlepin-tomcat6-0.9.37-1.el6.noarch
* elasticsearch-0.90.10-7.el6.noarch
* foreman-1.8.0-0.develop.201412181705git9e844ba.el6.noarch
* foreman-compute-1.8.0-0.develop.201412181705git9e844ba.el6.noarch
* foreman-gce-1.8.0-0.develop.201412181705git9e844ba.el6.noarch
* foreman-libvirt-1.8.0-0.develop.201412181705git9e844ba.el6.noarch
* foreman-ovirt-1.8.0-0.develop.201412181705git9e844ba.el6.noarch
* foreman-postgresql-1.8.0-0.develop.201412181705git9e844ba.el6.noarch
* foreman-proxy-1.8.0-0.develop.201412171625git51c455b.el6.noarch
* foreman-release-1.8.0-0.develop.201412181705git9e844ba.el6.noarch
* foreman-selinux-1.8.0-0.develop.201412151103gite2863e4.el6.noarch
* foreman-vmware-1.8.0-0.develop.201412181705git9e844ba.el6.noarch
* katello-2.1.0-1.201411061509gitb0b8f43.el6.noarch
* katello-certs-tools-2.0.1-1.el6.noarch
* katello-default-ca-1.0-1.noarch
* katello-installer-2.1.0-1.201412180333gitb02e8f2.el6.noarch
* katello-installer-base-2.1.0-1.201412180333gitb02e8f2.el6.noarch
* katello-repos-2.1.1-1.el6.noarch
* katello-server-ca-1.0-1.noarch
* openldap-2.4.39-8.el6.x86_64
* pulp-docker-plugins-0.2.1-0.2.beta.el6.noarch
* pulp-katello-0.3-3.el6.noarch
* pulp-nodes-common-2.5.0-0.7.beta.el6.noarch
* pulp-nodes-parent-2.5.0-0.7.beta.el6.noarch
* pulp-puppet-plugins-2.5.0-0.7.beta.el6.noarch
* pulp-puppet-tools-2.5.0-0.7.beta.el6.noarch
* pulp-rpm-plugins-2.5.0-0.7.beta.el6.noarch
* pulp-selinux-2.5.0-0.7.beta.el6.noarch
* pulp-server-2.5.0-0.7.beta.el6.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.3.3-1.el6.noarch
* ruby193-rubygem-net-ldap-0.10.0-1.el6.noarch
* ruby193-rubygem-runcible-1.3.0-1.el6.noarch
* rubygem-hammer_cli-0.1.4-1.el6.noarch
* rubygem-hammer_cli_foreman-0.1.4-1.el6.noarch
* rubygem-hammer_cli_foreman_bootdisk-0.1.2-1.el6.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3-2.201409091410gitc96619d.git.0.37f3704.el6.noarch
* rubygem-hammer_cli_import-0.10.4-1.el6.noarch
* rubygem-hammer_cli_katello-0.0.6-1.201412181307git280ed45.git.0.52b14f3.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. create activation_key with name "test"
2. search the key with name "test"
3. Now click the key and update its name with "mykey"
4. search "mykey"
5. UI doesn't show anything in search result

Actual results:
when you search the activation_key with updated name, search doesn't anything. However if you use old_name "test" then it will show updated name. see the screenshot.

Expected results:
Search should filter the key with updated name.

Additional info:

Comment 1 RHEL Program Management 2014-12-26 07:24:34 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Christine Fouant 2015-07-23 15:47:36 UTC
tested on 6.1 snap 14, and cannot reproduce the issue

Comment 4 Roman Plevka 2015-07-24 14:03:01 UTC
VERIFIED
tested on 6.1 snap 14
- works as supposed

Comment 7 errata-xmlrpc 2016-07-27 08:46:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.