Bug 117734 - Nautilus does not display /proc
Nautilus does not display /proc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-07 19:11 EST by Dan Williams
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 11:02:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Williams 2004-03-07 19:11:48 EST
Description of problem:
When using Nautilus to browse files, nautilus (nautilus 2.5.8-1) will
hang the window when browsing /proc.  Nautilus itself does _not_ hang,
but the the window that should show /proc hangs.

Version-Release number of selected component (if applicable):
nautilus 2.5.8-1

Steps to Reproduce:
1. Browse to /proc with nautilus
2. Hang in /proc window
Comment 1 Dan Williams 2004-03-07 22:29:40 EST
I am assuming this is the thread that is attempting to grab items to
display in the /proc window.

#0  0x005f4a52 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x006dc33b in __read_nocancel () from /lib/tls/libc.so.6
#2  0x00677e08 in _IO_file_read_internal () from /lib/tls/libc.so.6
#3  0x0067824f in _IO_file_xsgetn_internal () from /lib/tls/libc.so.6
#4  0x006799a8 in _IO_sgetn_internal () from /lib/tls/libc.so.6
#5  0x0066c8da in fread () from /lib/tls/libc.so.6
#6  0x0521f1b6 in gnome_vfs_get_mime_type_common () from
/usr/lib/libgnomevfs-2.so.0
#7  0x0521eadd in _gnome_vfs_mime_sniff_buffer_get () from
/usr/lib/libgnomevfs-2.so.0
#8  0x0521eedc in gnome_vfs_mime_type_from_name () from
/usr/lib/libgnomevfs-2.so.0
#9  0x0521ef34 in _gnome_vfs_get_mime_type_internal () from
/usr/lib/libgnomevfs-2.so.0
#10 0x0521f395 in gnome_vfs_get_mime_type_common () from
/usr/lib/libgnomevfs-2.so.0
#11 0x0521f407 in gnome_vfs_get_file_mime_type_fast () from
/usr/lib/libgnomevfs-2.so.0
#12 0x00ed5c71 in ?? () from /usr/lib/gnome-vfs-2.0/modules/libfile.so
#13 0x086061e8 in ?? ()
#14 0x04a77910 in ?? ()
#15 0x04a778e8 in ?? ()
#16 0x008e56ae in g_strdup () from /usr/lib/libglib-2.0.so.0
#17 0x00ed61f4 in ?? () from /usr/lib/gnome-vfs-2.0/modules/libfile.so
#18 0x085700b0 in ?? ()
#19 0x086061e8 in ?? ()
#20 0x00000009 in ?? ()
#21 0x04a77910 in ?? ()
#22 0x00742fec in ?? () from /lib/tls/libc.so.6
#23 0x007447c0 in __after_morecore_hook () from /lib/tls/libc.so.6
#24 0x04a77910 in ?? ()
#25 0x0855c3a0 in ?? ()
#26 0x00000003 in ?? ()
Comment 2 Alexander Larsson 2004-03-08 05:56:56 EST
Its trying to sniff the mimetype of some file.
Need debug info to know the name of the file.
Comment 3 Alexander Larsson 2004-10-04 10:53:58 EDT
Seems to work for me in fc3test3. Do you still see it with rawhide?
Comment 4 Dan Williams 2004-10-04 11:02:42 EDT
yep, worksforme
Comment 5 Daniel Riek 2005-05-16 10:20:05 EDT
I am still seeing what looks like this problem in nautilus-2.10.0-4 from rawhide
when I start it as root. Normal users work.

Note You need to log in before you can comment on or make changes to this bug.