Bug 1177379 - Can't run java application in headless mode
Summary: Can't run java application in headless mode
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk
Version: 21
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-26 19:50 UTC by Mounir
Modified: 2016-03-03 16:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-03 16:02:12 UTC


Attachments (Terms of Use)

Description Mounir 2014-12-26 19:50:24 UTC
Description of problem:

After installing Fedora 21 Workstation, I downloaded PyCharm Community Edition but it canno't run with this output error: application cannot start in headless mode.

The problem was resolved by installing java-1.8.0-openjdk-devel 


Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. A fresh instal of Fedora 21 Workstation
2. downloading PyCharm 4 Community Edition
3. unzip the downloaded tar
4. run pycharm_folder/bin/pycharm.sh

Actual results:
Program canno't run

Expected results:
Program run

Additional info:
I think it's related with xorg window

Comment 1 Deepak Bhole 2015-01-05 14:11:04 UTC
Are you sure this is Java related? The PyCharm quickstart page makes no mention of a Java requirement:
https://www.jetbrains.com/pycharm/quickstart/

Comment 2 Mounir 2015-01-05 15:12:26 UTC
Go to https://www.jetbrains.com/pycharm/download/ and click on System Requirements.

System Requirements

    512 MB RAM minimum, 1 GB RAM recommended
    1024x768 minimum screen resolution
    Oracle JRE 1.6+ or OpenJDK 1.7+
    Python 2.4 or higher, Jython, PyPy or IronPython

Comment 3 Deepak Bhole 2015-01-05 18:57:44 UTC
(In reply to Mounir from comment #2)
> Go to https://www.jetbrains.com/pycharm/download/ and click on System
> Requirements.
> 
> System Requirements
> 
>     512 MB RAM minimum, 1 GB RAM recommended
>     1024x768 minimum screen resolution
>     Oracle JRE 1.6+ or OpenJDK 1.7+
>     Python 2.4 or higher, Jython, PyPy or IronPython

Ah okay. I tried running this and ran into the same issue -- the proper resolution is to install java-1.8.0-openjdk (depending on what pycharm does, -devel may be needed to). 

The inability to run it with only -headless installed is expected as the -headless package does not have the necessary GUI libraries.

Closing as NOTABUG.

Comment 4 Mounir 2015-01-05 19:33:38 UTC
(In reply to Deepak Bhole from comment #3)
> (In reply to Mounir from comment #2)
> > Go to https://www.jetbrains.com/pycharm/download/ and click on System
> > Requirements.
> > 
> > System Requirements
> > 
> >     512 MB RAM minimum, 1 GB RAM recommended
> >     1024x768 minimum screen resolution
> >     Oracle JRE 1.6+ or OpenJDK 1.7+
> >     Python 2.4 or higher, Jython, PyPy or IronPython
> 
> Ah okay. I tried running this and ran into the same issue -- the proper
> resolution is to install java-1.8.0-openjdk (depending on what pycharm does,
> -devel may be needed to). 
> 
> The inability to run it with only -headless installed is expected as the
> -headless package does not have the necessary GUI libraries.
> 
> Closing as NOTABUG.

May be it's not a bug but I think it would be more confortable for users to have GUI librairies installed by default in Fedora Workstation.

Comment 5 Deepak Bhole 2015-01-06 14:54:31 UTC
The GUI libraries are installed if the Java group is selected during install. The package name (java-1.8.0-openjdk) is listed in the comps.xml:
https://git.fedorahosted.org/cgit/comps.git/tree/comps-f21.xml.in

Comment 6 Martin Bříza 2016-03-03 15:51:59 UTC
This happens again after an update between 1:1.8.0.72-7.b15.fc23.x86_64 and 1:1.8.0.72-4.b15.fc23.x86_64.
I have ever java-1.8.0-openjdk package installed and Pycharm doesn't start.

Comment 7 Martin Bříza 2016-03-03 16:02:12 UTC
So to let everyone know: After updating to java-1.8.0-openjdk.x86_64 1:1.8.0.72-9.b16.fc23 from updates-testing, this is fixed again.


Note You need to log in before you can comment on or make changes to this bug.