Bug 1177503 - python-txrequests doesn't belong to epel7 because of conflicting build requirements
Summary: python-txrequests doesn't belong to epel7 because of conflicting build requir...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-txrequests
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Ralph Bean
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-28 10:27 UTC by Tuomo Soini
Modified: 2015-02-18 16:52 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-02-18 16:52:59 UTC


Attachments (Terms of Use)

Description Tuomo Soini 2014-12-28 10:27:23 UTC
Description of problem:

You can't build python-txrequests for epel7 any more because it has build requirement for python-requets >= 1.2.0 which was on koji when package was build. But that package got removed because there is older version of python-requets in rhel7.

Please fix package to work with python-requests = 1.1.0-8.el7 or remove the broken package from epel7.

Comment 1 Tuomo Soini 2014-12-29 06:41:14 UTC
Sorry, reported against wrong epel version.

Comment 2 Ralph Bean 2015-01-05 18:08:20 UTC
After some local testing, it looks like that the version pinning on requests-1.2.0 is unnecessary.  Everything works fine in a virtualenv with requests-1.1.0.

Comment 3 Fedora Update System 2015-01-05 18:13:52 UTC
python-txrequests-0.9.2-3.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/python-txrequests-0.9.2-3.el7

Comment 4 Fedora Update System 2015-01-24 18:47:40 UTC
python-txrequests-0.9.2-3.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.