Bug 117753 (iptables-save) - "service iptables save" saves syntactically wrong rule in /etc/sysconfig/iptables
Summary: "service iptables save" saves syntactically wrong rule in /etc/sysconfig/ipta...
Status: CLOSED DUPLICATE of bug 111999
Alias: iptables-save
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: iptables   
(Show other bugs)
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-08 07:48 UTC by Demosthenes T. Mateo Jr.
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Demosthenes T. Mateo Jr. 2004-03-08 07:48:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
"service iptables save" creates this line in /etc/sysconfig/iptables:

-A RH-Firewall-1-INPUT -p icmp -m icmp any -j ACCEPT

Next time you do "service iptables start" you get this error:

Applying iptables firewall rules: Bad argument `any'

Version-Release number of selected component (if applicable):
iptables-1.2.8-12

How reproducible:
Always

Steps to Reproduce:
1. redhat-config-securitylevel-tui
2. select Enabled then create empty rule or select/add any port
3. save your options
4. service iptables start
5. service iptables save
6. service iptables restart
    

Actual Results:  Applying iptables firewall rules: Bad argument `any'
Error occured at line: 10
Try `iptables-restore -h' or 'iptables-restore --help' for more
information.

Expected Results:  Should have restarted and activated the iptables rules.

Additional info:

Comment 1 Thomas Woerner 2004-03-09 16:43:27 UTC

*** This bug has been marked as a duplicate of 111999 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:01:52 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.