Bug 1177597 - can not use PS/2 mouse on migration destination
Summary: can not use PS/2 mouse on migration destination
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.1
Hardware: x86_64
OS: Unspecified
medium
high
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-29 10:15 UTC by Jun Li
Modified: 2015-12-04 16:24 UTC (History)
7 users (show)

Fixed In Version: qemu 2.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:24:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Jun Li 2014-12-29 10:15:56 UTC
Description of problem:
boot guest and then do migration. Can not use the PS/2 mouse inside dst guest after migration.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.1.2-17.el7.x86_64
Host kernel:
3.10.0-220.el7.x86_64
guest:
win2012r2-64

How reproducible:
100%

Steps to Reproduce:
1.boot guest cli:
# /usr/libexec/qemu-kvm -name test -machine pc,dump-guest-core=off -cpu Broadwell,+movbe,+bmi1,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff,hv_time,check,enforce -enable-kvm -sandbox on -m 2G -vnc :1 -realtime mlock=off -smp 4,sockets=1,cores=2,threads=2 -uuid b123c5df-d85b-2ce9-5e93-926f4f4ce03b -nodefconfig -nodefaults -rtc base=utc -drive file=/home/win2012r2-64.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,snapshot=on -device virtio-blk-pci,bus=pci.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:13:20:fe:11:11,bus=pci.0 -drive file=/home/en_windows_server_2012_r2_x64_dvd_2707946.iso,if=none,id=iso1,media=cdrom -device ide-cd,drive=iso1,id=sys-iso1 -drive file=/usr/share/virtio-win/virtio-win-1.7.2.iso,if=none,id=virtio-win-driver,media=cdrom -device ide-cd,drive=virtio-win-driver,id=sys-virtio-win-driver -monitor stdio -vga cirrus
2.boot dst guest cli(on the same host).
# /usr/libexec/qemu-kvm -name test -machine pc,dump-guest-core=off -cpu Broadwell,+movbe,+bmi1,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff,hv_time,check,enforce -enable-kvm -sandbox on -m 2G -vnc :2 -realtime mlock=off -smp 4,sockets=1,cores=2,threads=2 -uuid b123c5df-d85b-2ce9-5e93-926f4f4ce03b -nodefconfig -nodefaults -rtc base=utc -drive file=/home/win2012r2-64.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,snapshot=on -device virtio-blk-pci,bus=pci.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:13:20:fe:11:11,bus=pci.0 -drive file=/home/en_windows_server_2012_r2_x64_dvd_2707946.iso,if=none,id=iso1,media=cdrom -device ide-cd,drive=iso1,id=sys-iso1 -drive file=/usr/share/virtio-win/virtio-win-1.7.2.iso,if=none,id=virtio-win-driver,media=cdrom -device ide-cd,drive=virtio-win-driver,id=sys-virtio-win-driver -monitor stdio -vga cirrus -incoming tcp::5800
tap1
3.do migration from src to dst.
(qemu) migrate -d tcp:127.0.0.1:5800
4.check the guest mouse can be used or not inside dst guest.

Actual results:
After step4, can not use the mouse inside dst guest.

(qemu) info mice 
* Mouse #2: QEMU PS/2 Mouse

Expected results:
Can use the mouse as normal inside dst guest.

Additional info:

Comment 2 Gerd Hoffmann 2015-04-30 09:00:18 UTC
Doesn't reproduce.  Please retest with qemu 2.3

Comment 3 Jun Li 2015-05-05 06:34:53 UTC
Retest with qemu-kvm-rhev-2.3.0-1.el7.x86_64.


cli:
# /usr/libexec/qemu-kvm -name test -machine pc,dump-guest-core=off -cpu Broadwell,+movbe,+bmi1,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff,hv_time,check -enable-kvm -sandbox on -m 2G -vnc :1 -realtime mlock=off -smp 4,sockets=1,cores=2,threads=2 -uuid b123c5df-d85b-2ce9-5e93-926f4f4ce03b -nodefconfig -nodefaults -rtc base=utc -drive file=/mnt/windows_img/win2012-64r2-virtio.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,snapshot=on -device virtio-blk-pci,bus=pci.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:13:20:fe:11:11,bus=pci.0 -drive file=/home/en_windows_server_2012_r2_x64_dvd_2707946.iso,if=none,id=iso1,media=cdrom -device ide-cd,drive=iso1,id=sys-iso1 -drive file=/usr/share/virtio-win/virtio-win-1.7.2.iso,if=none,id=virtio-win-driver,media=cdrom -device ide-cd,drive=virtio-win-driver,id=sys-virtio-win-driver -monitor stdio -vga cirrus

Steps the same with comment #0, repeat try 3 times, do not hit this issue.

Comment 4 Gerd Hoffmann 2015-05-05 07:35:14 UTC
(In reply to Jun Li from comment #3)
> Retest with qemu-kvm-rhev-2.3.0-1.el7.x86_64.

> Steps the same with comment #0, repeat try 3 times, do not hit this issue.

rebase fixed this appearently.  setting to modified then.

Comment 5 Shaolong Hu 2015-06-18 09:00:40 UTC
Verified on qemu-kvm-rhev-2.3.0-2.el7.x86_64:

1. boot guest on src host:
/usr/libexec/qemu-kvm -name test -machine pc,dump-guest-core=off -cpu Broadwell,+movbe,+bmi1,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff,hv_time,check -enable-kvm -sandbox on -m 2G -vnc :1 -realtime mlock=off -smp 4,sockets=1,cores=2,threads=2 -uuid b123c5df-d85b-2ce9-5e93-926f4f4ce03b -nodefconfig -nodefaults -rtc base=utc -drive file=/mnt/windows_img/win2012-64r2-virtio.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,snapshot=on -device virtio-blk-pci,bus=pci.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:13:20:fe:11:11,bus=pci.0 -drive file=/home/en_windows_server_2012_r2_x64_dvd_2707946.iso,if=none,id=iso1,media=cdrom -device ide-cd,drive=iso1,id=sys-iso1 -drive file=/usr/share/virtio-win/virtio-win-1.7.2.iso,if=none,id=virtio-win-driver,media=cdrom -device ide-cd,drive=virtio-win-driver,id=sys-virtio-win-driver -monitor stdio -vga cirrus

2. boot guest on same host, with same cmd plus "-incoming tcp:0:5555"

3. do migration:
(qemu) migrate -d tcp:127.0.0.1:5555

4. after migration, guest mice works correctly.

Comment 12 errata-xmlrpc 2015-12-04 16:24:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.