Bug 117762 - km400 video chipset unsupported
km400 video chipset unsupported
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-08 06:11 EST by grayshade
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 14:45:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description grayshade 2004-03-08 06:11:30 EST
there's a linux driver for the S3 Unichrome video chipset (used in VIA
KM400-based motherboards) hanging around the net (namely at
www.viaarena.com), but there's no support for it in Fedora Core test1
setup. I can only manage to run X in VESA-compatible mode.
the VIA installer crashes as it doesn't recognize Fedora. moreover I'm
not sure if that driver is compatible with the new 2.6 series kernel.
Comment 1 D.Branchini 2004-03-24 06:34:00 EST
I've got the same problem: dmesg says "chipset unsupported" (I've got 
a motherboard with VIA KM400)... I'm using a Radeon 7000 instead of 
the internal device.
X works, but SLOW (no agp module, no direct rendering...)
Comment 2 Barry Stewart 2004-03-29 22:23:50 EST
Still unsupported in FC2-test2.  Could not complete installation (X
dies on first reboot with "Screens found, but no usable configuration"
or something like that, using the vesa driver chosen by the
installer). I copied over a known working XFConfig file and got X to
start successfully using the "via" X driver, but got "Failed to load
kernel module agpgart" and "failed to load kernel module "via" in
/var/log/XFree86.0.log.  I'm using an Asus A7V8X-MX motherboard with
the KM400 chipset.
Comment 3 D.Branchini 2004-04-26 10:53:37 EDT
www.viaarena.com released module sources for kernel 2.4. You need the 
kernel sources AND the Via files, they give you step-by-step 
instrucions to compile and install the module. I didn't work for me, 
but I know nothing about kernel compiling (so I hate to say it, but I 
have to say it, it's probably me...)
Comment 4 Mike A. Harris 2004-10-12 14:45:33 EDT
Since this bugzilla report was filed, there have been several
updates to the via driver included in Fedora Core.  Users are
encouraged to upgrade to the latest version of Fedora Core,
which can be obtained from:

        http://fedora.redhat.com/download

If the included driver is lacking functionality you would like
to see in a future X.Org release, please file a bug report in
the X.Org bugzilla at http://bugs.freedesktop.org in the "xorg"
component, pointing to any external driver sources which are newer,
and indicating it is a feature enhancement request.

Once you've filed your bug report to X.Org, it will be tracked
by X.Org developers, and once reviewed for consideration, a future
X.Org release may provide the requested functionality.

Note You need to log in before you can comment on or make changes to this bug.