Bug 117763 - binutils BuildRequires missing flex
binutils BuildRequires missing flex
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-08 06:45 EST by Steve Grubb
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-08 17:53:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2004-03-08 06:45:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
The source rpm specfile is missing a BuildRequires tag for flex. It
will not compile if flex is missing.

Version-Release number of selected component (if applicable):
binutils-2.14.90.0.8-8

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bb /usr/src/redhat/SPEC/binutils.spec

    

Actual Results:  Error building rpm

Expected Results:  rpm package created

Additional info:
Comment 1 Warren Togami 2004-04-18 10:32:43 EDT
http://people.redhat.com/wtogami/temp/binutils-build-failure.txt
Confirmed flex in fedora.us-buildsys, however the build fails later
due to other missing BuildRequires.  Please find the exact missing
BuildRequires and report back.
Comment 2 Steve Grubb 2004-04-18 12:17:49 EDT
Installing flex made it work for me. I'm not sure what else it needed.
But according to the missing file: aclocal, autoconf, autoheader,
automake, bison, flex, help2man, makeinfo, & tar.
Comment 3 Jakub Jelinek 2004-05-27 10:51:31 EDT
Commited to cvs.devel, so will show up in 2.15.90.0.3-8 when it is built.
Comment 4 Steve Grubb 2004-06-04 12:39:14 EDT
FWIW, this is what I'm using now:

--- working/binutils/binutils.spec      2004-05-19 12:16:05.000000000
-0400
+++ /opt/specs/binutils.spec    2004-05-31 12:21:03.000000000 -0400
@@ -21,7 +21,7 @@
 Patch13: binutils-2.15.90.0.3-ia64-lib64.patch
                                                                     
          
 Buildroot: /var/tmp/binutils-root
-BuildRequires: texinfo >= 4.0, dejagnu, gettext
+BuildRequires: texinfo >= 4.0, dejagnu, gettext, flex, bison
 Prereq: /sbin/install-info
 %ifarch ia64
 Obsoletes: gnupro
Comment 5 Alan Cox 2004-08-08 17:53:06 EDT
Added bison too and set it building

Note You need to log in before you can comment on or make changes to this bug.