Bug 117766 - up2date --get-source fails with yum repos in sources
up2date --get-source fails with yum repos in sources
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks: up2date-rhel3-u2
  Show dependency treegraph
 
Reported: 2004-03-08 07:05 EST by Paul Nasrat
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.2.38
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 17:57:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix yumRepo (778 bytes, patch)
2004-03-08 07:09 EST, Paul Nasrat
no flags Details | Diff

  None (edit)
Description Paul Nasrat 2004-03-08 07:05:32 EST
Description of problem:

Adding jpackage repos to RHEL ES and running up2date --get-source fails.
[pauln@deathstar repoBackends]$ sudo up2date --get-source log4j
 
Fetching all package list for channel: rhel-i386-es-3...
########################################
 
Fetching all package list for channel: jpackage-free...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1190, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 687, in main
    return getPackages(pkgNames, source=1)
  File "/usr/sbin/up2date", line 948, in getPackages
    progressCallback = wrapperUtils.percent)
  File "rhnPackageInfo.py", line 263, in getAllAvailableAllArchPackageList
  File "rhnPackageInfo.py", line 202, in allAvailablePackageList
  File "rpcServer.py", line 112, in doCall
  File "repoDirector.py", line 23, in listAllPackages
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 238, in
listAllPackages
    msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
281, in listAllPackages
    return self.listPackages(channel, version, msgCallback,
progressCallback)
TypeError: listPackages() takes at most 4 arguments (5 given)



Version-Release number of selected component (if applicable):

up2date-4.2.5-1


How reproducible:

Always

Steps to Reproduce:
1. add to /etc/sysconfing/rhn/sources
yum jpackage-free
ftp://jpackage.hmdc.harvard.edu/JPackage/1.5/generic/free

2. up2date --get-source log4j

  
Actual results:

Trace above
Expected results:

it works



Additional info:

Fixed patch to follow.
Comment 1 Paul Nasrat 2004-03-08 07:09:45 EST
Created attachment 98367 [details]
Patch to fix yumRepo

This fixes --get-source for me
Comment 2 Paul Nasrat 2004-03-08 08:09:34 EST
Further investigation shows that there are probably more fixes that
need to be done.  Just tried adding another repo and it fails.  I'll
try and get some more information, but you may have seen this before.

[pauln@deathstar tmp]$ grep -e ^yum /etc/sysconfig/rhn/sources
yum vs-stuff http://cachalot.mine.nu/1
[pauln@deathstar tmp]$ sudo up2date -l
Password:
                                                                     
                                                                     
                                        
Fetching package list for channel: vs-stuff...
                                                                     
                                                                     
                                        
Fetching http://cachalot.mine.nu/1/headers/header.info...
########################################
                                                                     
                                                                     
                                        
Fetching Obsoletes list for channel: vs-stuff...
                                                                     
                                                                     
                                        
Fetching rpm headers...
                                                                     
                                                                     
                                        
Name                                    Version        Rel
----------------------------------------------------------
                                                                     
                                                                     
                                        
[pauln@deathstar tmp]$ sudo up2date --get-source bugzilla
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
D: availablePackageList::channels:
<up2date_client.rhnChannel.rhnChannelList instance at 0x8364384>
                                                                     
                                                                     
                                        
Fetching all package list for channel: vs-stuff...
D: add instance class name diskcache
D: add instance class name yum
                                                                     
                                                                     
                                        
Fetching http://cachalot.mine.nu/1/headers/header.info...
D: add instance class name diskcache
D: add instance class name yum
                                                                     
                                                                     
                                        
Fetching http://cachalot.mine.nu/1/headers/header.info...
D: add instance class name diskcache
D: add instance class name yum
                                                                     
                                                                     
                                        
... untill I Ctrl-C
Comment 3 Paul Nasrat 2004-03-08 08:16:25 EST
Ignore comment 2 - it seems to be a repo issue.
Comment 4 Adrian Likins 2004-03-22 16:44:55 EST
apt/dir/yumrepo support in rhel is pretty broken, I'll take
a look at trying to fix for u3
Comment 5 Adrian Likins 2004-04-06 15:44:22 EDT
should be fixed in 4.2.9
Comment 6 Elliot Peele 2004-04-27 19:19:58 EDT
Any idea when 4.2.9 is going to be released?
Comment 7 Todd Warner 2004-08-26 19:47:59 EDT
Definately fixed in 4.2.38 which is going out Real Soon Now[tm] so...
PROD_READYing this.

Note You need to log in before you can comment on or make changes to this bug.