Bug 1177765 - Missing filter on listing only composite content views
Summary: Missing filter on listing only composite content views
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: API
Version: 6.0.6
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1122832 GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-12-30 10:31 UTC by Peter Vreman
Modified: 2019-09-25 21:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:46:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 13837 None None None 2016-04-22 16:17:07 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Peter Vreman 2014-12-30 10:31:32 UTC
Description of problem:
The current noncomposite filter is only a filter that allows excluding of the composite content views. It is not possible to retrieve only the composite content views instead. This is therefor a strange filter, it would be more intuitive and consistent to have a "composite" filter, when set then check if the composite value matches.

# curl -K /opt/hoici/etc/curl-hoici.conf -H 'Content-Type: application/json' -d '{"per_page":9999,"noncomposite":false}' -XGET https://localhost/katello/api/v2/organizations/4/content_views | jq .results[].composite
true
null
null
null
null
null
true
null
null
true
null
null
null
null


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a Composite Content View
2. Create a regular content view
3. List only the composite content view

Actual results:
regular content view is also included

Expected results:
only composite content views are listed

Additional info:

Comment 1 RHEL Program Management 2014-12-30 10:54:10 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Mike McCune 2015-01-08 16:29:22 UTC
This is more of a bug, adjusting accordingly

Comment 4 Partha Aji 2016-02-22 15:06:40 UTC
Created redmine issue http://projects.theforeman.org/issues/13837 from this bug

Comment 5 Bryan Kearney 2016-02-23 01:03:07 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/13837 has been closed
-------------
David Davis
Applied in changeset commit:katello|ce6941cd3934f55c358669762c2486b8e4cb367b.

Comment 8 jcallaha 2016-04-05 13:38:19 UTC
Verified in Satellite 6.2 Beta Snap 6 Compose 1.

You can now filter the results to include only composite content views.

{"composite":true}

Comment 10 errata-xmlrpc 2016-07-27 08:46:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.