Bug 1177773 - [RFE][HC] - Brick scaling and balancing when adding storage on hyper converged nodes. [NEEDINFO]
Summary: [RFE][HC] - Brick scaling and balancing when adding storage on hyper converge...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: HC_Host_4.0
TreeView+ depends on / blocked
 
Reported: 2014-12-30 11:53 UTC by Yaniv Lavi
Modified: 2018-11-19 05:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-19 05:20:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
nbalacha: needinfo? (ylavi)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github 558 0 None None None 2018-11-19 05:48:34 UTC

Description Yaniv Lavi 2014-12-30 11:53:47 UTC
Description of problem:
We need to be able to smartly scale hosts and rebalance images (limitations and best-practices). This feature should take in account possible bottlenecks, network data transfer spikes and data locality.

Comment 1 Niels de Vos 2015-01-06 13:12:40 UTC
Sounds like distribute to me, the replicate counterpart is bug 1177775.

Comment 2 Nithya Balachandran 2018-11-12 03:15:42 UTC
Please provide more details of what you would expect rebalance to do. There have been several changes since the BZ was opened.

Comment 3 Vijay Bellur 2018-11-19 05:48:34 UTC
Migrated to github:

https://github.com/gluster/glusterfs/issues/558

Please follow the github issue for further updates on this bug.


Note You need to log in before you can comment on or make changes to this bug.