Bug 1177776 - [RFE][HC] – Add libgfapi support, that will allow native gluster volume access.
Summary: [RFE][HC] – Add libgfapi support, that will allow native gluster volume access.
Keywords:
Status: CLOSED DUPLICATE of bug 1022961
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.6.0
Assignee: Dan Kenigsberg
QA Contact: Aharon Canan
URL:
Whiteboard: gluster
Depends On: 1181466
Blocks: 922744 Generic_Hyper_Converged_Host
TreeView+ depends on / blocked
 
Reported: 2014-12-30 11:57 UTC by Yaniv Lavi
Modified: 2016-02-10 19:29 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-30 06:43:57 UTC
oVirt Team: Gluster


Attachments (Terms of Use)

Description Yaniv Lavi 2014-12-30 11:57:05 UTC
Description of problem:
Currently gluster volumes have to be mounted and images are created/accessed over the mount. With the introduction of GlusterFS libgfapi, QEMU supports glusterfs through libgfapi directly. This we call as QEMU driver for glusterfs.


A build of VDSM with this support was created in:
http://jenkins.ovirt.org/job/vdsm_libgfapi_master_create_rpms_nightly/search/?q=vdsm_master-libgfapi_create-rpms
We need to test this functionality.

Comment 1 Yaniv Lavi 2015-03-19 09:40:10 UTC
*** Bug 1177777 has been marked as a duplicate of this bug. ***

Comment 2 Nikolai Sednev 2015-04-28 16:13:49 UTC
(In reply to Yaniv Dary from comment #0)
> Description of problem:
> Currently gluster volumes have to be mounted and images are created/accessed
> over the mount. With the introduction of GlusterFS libgfapi, QEMU supports
> glusterfs through libgfapi directly. This we call as QEMU driver for
> glusterfs.
> 
> 
> A build of VDSM with this support was created in:
> http://jenkins.ovirt.org/job/vdsm_libgfapi_master_create_rpms_nightly/search/
> ?q=vdsm_master-libgfapi_create-rpms
> We need to test this functionality.

The path is empty, "http://jenkins.ovirt.org/job/vdsm_libgfapi_master_create_rpms_nightly/search/?q=vdsm_master-libgfapi_create-rpms"

Comment 4 Sandro Bonazzola 2015-04-30 06:43:57 UTC

*** This bug has been marked as a duplicate of bug 1022961 ***


Note You need to log in before you can comment on or make changes to this bug.