Bug 117790 - Epiphany Install while in desktop doesn't work
Summary: Epiphany Install while in desktop doesn't work
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libbonobo (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-03-08 17:17 UTC by Alexander Larsson
Modified: 2013-04-02 04:19 UTC (History)
6 users (show)

Fixed In Version: libbbonobo-2.8.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 09:53:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Larsson 2004-03-08 17:17:34 UTC
If you install the rpm while running the gnome desktop the app doesn't
work. Launching epi gives some bonobo-activation error. Restarting
bonobo-activation makes it work. We should probably do some magic in
%post?

Comment 1 Christopher Blizzard 2004-03-08 21:26:14 UTC
I don't know enough about the activation stuff to know how to fix
this.  Can you hup it?  Is there some kind of rescan command?

Comment 2 Alexander Larsson 2004-03-15 16:44:54 UTC
I'm not really sure, and there might be several bonobo-activation
running... Also, i think no other packages are doing this.

Comment 3 Brent Fox 2004-03-24 17:10:03 UTC
I'm seeing this too with the rawhide-latest tree.

Comment 4 Warren Togami 2004-04-17 11:02:12 UTC
I just tried this, seems to work for me.  Can anybody confirm?

Comment 5 Colin Charles 2004-05-07 12:13:21 UTC
I just installed epiphany 1.1.12-0 and the problem exists (with
today's rawhide tree). Comes out as a Question dialog, with the message:

"Bonobo couldn't locate the GNOME_Epiphany_Automation. server file.
You can use bonobo-activation-sysconf to configure the search path for
bonobo server files." 

Option is to click Cancel. And yes, restarting bonobo-activation
solves the problem. 

Comment 6 Colin Charles 2004-05-09 10:10:26 UTC
epiphany-1.2.4-1 from the new tree fixes this, on my system.

Comment 7 Brion Vibber 2004-09-28 05:34:40 UTC
I just saw this problem on Fedora Core 2, installing
epiphany-1.2.7-0.2.2. Reopen?

I'm up to date on FC2 package updates, and also have some packages
installed from Fedora.us extras and the Ximian Mono packages.

Comment 8 Brion Vibber 2004-09-28 06:27:32 UTC
Trying to launch it again about an hour after installation seems to be
working, but it would be nice to have it work immediately after
installation.


Comment 9 Mark McLoughlin 2004-09-28 06:31:37 UTC
bonobo-activation-server re-scans the .server files before processing
a query if it hasn't scanned within the last 5 seconds.

So, I wouldn't expect to see this problem for more than 5 seconds
after installing the package.

Comment 10 Mark McLoughlin 2004-09-28 06:40:14 UTC
Correction, it checks the mtime on /usr/lib/bonobo/servers rather than
the .server files itself. Perhaps that's the issue here - if the file
gets overwritten rather than removed and then re-written, then the
mtime wouldn't change?

Comment 11 Mark McLoughlin 2004-09-28 09:35:02 UTC
Okay, it turns out that the check-registry-mtime stuff wasn't being
invoked with the unusual activation method epiphany uses.

Have a fix for bonobo-activation-server

Comment 12 Mark McLoughlin 2004-09-28 09:53:37 UTC
Fixed upstream:

  http://bugzilla.gnome.org/show_bug.cgi?id=145169

Backported patch in libbonobo-2.8.0-2


Note You need to log in before you can comment on or make changes to this bug.