Bug 1177959 - mountmgr.sys not copying on install - fs not mountable as win drives
Summary: mountmgr.sys not copying on install - fs not mountable as win drives
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: wine
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-31 16:55 UTC by Joe Greene
Modified: 2015-11-10 16:52 UTC (History)
5 users (show)

Fixed In Version: wine-1.7.53-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-10 16:52:08 UTC


Attachments (Terms of Use)

Description Joe Greene 2014-12-31 16:55:55 UTC
Description of problem:
fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2


Version-Release number of selected component (if applicable):
Fresh install Red Hat Enterprise Linux Server release 7.0 (Maipo)
wine.x86_64 1.7.22-1.el7 @epel


How reproducible:
Consistent

Steps to Reproduce:
1.AWS RHEL 7 image. 
2. install epel repo
3. yum install wine*
4. exec 'wineconsole' or 'winefile' or 'winecfg' or 'wine notepad'
5. exit
6. exec 'wineconsole' or 'winefile' or 'winecfg' or 'wine notepad'
7. Error appears. No mapped drives


Actual results:
Instance which builds wineprefix functions but all further attempts fail to start MountMgr service listed above and thus do not map C: or any other drives. UNLESS one manually copies /usr/lib64/wine/fakedlls/mountmgr.sys to ${WINEPREFIX}/drive_c/windows/system32/drivers/mountmgr.sys

Expected results:
MountMgr is a critical service. All other working wine builds I have checked do indeed copy the mountmgr.sys to the windows/system32/drivers directory.

Additional info:
Workaround: copy /usr/lib64/wine/fakedlls/mountmgr.sys to ${WINEPREFIX}/drive_c/windows/system32/drivers/mountmgr.sys
Problems executing windows binaries persist, likely due to similar file copy issues - investigating further.

Comment 1 Joe Greene 2015-01-08 14:47:04 UTC
Wine will not function as strictly 64bit . Too much of it's base architecture still relies on 32bit components. The workaround above is actually copying a 64bit component into the place of something that should be a 32bit component, making it a small, questionable miracle that it works at all. With this wine installation using strictly 64bit , Win32 programs do not function, the EXE files all report as invalid. Thus any program which Windows Vista and above would install in "C:\Program Files (x86)\" by default will not run under wine compiled in strictly 64bit mode.

Comment 2 Fabien Archambault 2015-10-21 12:14:25 UTC
Thanks for the tip to make wine work back.

$ cp /usr/lib64/wine/fakedlls/mountmgr.sys ~/.wine/drive_c/windows/system32/drivers/

Comment 3 Fedora Update System 2015-10-22 02:00:14 UTC
wine-1.7.53-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-be28274c11

Comment 4 Fedora Update System 2015-10-26 21:21:04 UTC
wine-1.7.53-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update wine'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-be28274c11

Comment 5 Fedora Update System 2015-11-10 16:52:02 UTC
wine-1.7.53-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.