Bug 1177976 - Windows EFI partition trashed by install convenience option.
Summary: Windows EFI partition trashed by install convenience option.
Keywords:
Status: CLOSED DUPLICATE of bug 1183880
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-31 22:17 UTC by Dominick Samperi
Modified: 2015-08-03 13:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-03 13:41:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Dominick Samperi 2014-12-31 22:17:25 UTC
Description of problem:
Under custom partitioning, if one of the partitions of an old Fedora install are deleted the user is presented with a checkbox that when checked will cause ALL partitions associated with this "old" installation to be deleted. If this old install uses the Windows EFI system partition, then the Windows EFI system partition is deleted as well! The result is that the machine can no longer boot windows.

Version-Release number of selected component (if applicable):
The Fedora x86_64 Live DVD was used to install on an ASUS laptop (X200M).

How reproducible:
Install Fedora 21 with custom partitioning, no problem.
Now assume that for some reason you want to start over. Run the
Live DVD install again, and delete all partitions that were previously
created for Fedora 21. This causes the Windows EFI system partition to
be deleted (the Windows data partition is still there, but it cannot
be booted).

Steps to Reproduce:
1.Install Fedora 21
2.Install again, but this time delete all partitions associated with first install.
3.

Actual results:
Windows EFI system partition is deleted.

Expected results:
Should NEVER delete Windows EFI system partition.

Additional info:

Comment 1 David Shea 2015-08-03 13:41:39 UTC

*** This bug has been marked as a duplicate of bug 1183880 ***


Note You need to log in before you can comment on or make changes to this bug.