Bug 117798 - Installer does not give option to change drive when doing bootloader upgrade
Installer does not give option to change drive when doing bootloader upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-08 13:34 EST by Rick Wagner
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-08 14:59:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Wagner 2004-03-08 13:34:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040130

Description of problem:
Upgrade from RH9, which was SCSI only when RH9 was installed.  Later
added IDE drive as bulk storage (backups, etc).  Since the IDE drive
was added after the system was installed, and was just a "data-tub",
it was not bootable.  Therefore it was disabled in the BIOS.  Initial
boot after install worked, but subsequent boot after package updates
failed; just printed GRUB loading message.

After hours in grub he**, decided to try re-upgrading.  During the
second re-upgrade attempt, I selected third option (I think it is
"install boot loader"; was NOT "upgrade", and NOT "leave alone"). 
Next screen showed the device to be installed upon.  It was there I
noticed that it was going to install on HDA (IDE drive).  This is
probably a fair assumption, but in this case wrong, with no option to
change.  By unplugging my IDE drive, and re-running, GRUB was properly
re-installed, and the system booted and is alive (yeah!) allowing me
to file a bugzilla report.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
Don't have a similar configuration I can try this on.

Actual Results:  GRUB appearantly installed on wrong drive.  Didn't
have an option to choose which.

Expected Results:  Should have been able to select drive to install
MBR on.

Additional info:
Comment 1 Jeremy Katz 2004-03-08 14:59:49 EST
Upgrade just leaves the config as is except for changing the kernels.
 If you select to install a new boot loader, you can change the drive
ordering in the "advanced boot loader" screen.

Note You need to log in before you can comment on or make changes to this bug.