Bug 1178009 - [RHEVM][FOREMAN-INTEGRATION] picking "Use Foreman Hosts Providers" removes the "Use JSON protocol"
Summary: [RHEVM][FOREMAN-INTEGRATION] picking "Use Foreman Hosts Providers" removes th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Yaniv Bronhaim
QA Contact: movciari
URL:
Whiteboard: infra
Depends On:
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2015-01-01 11:51 UTC by Yaniv Bronhaim
Modified: 2016-02-10 19:38 UTC (History)
12 users (show)

Fixed In Version: vt13.7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-15 09:14:18 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0230 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.5.0-1 ASYNC 2015-02-16 19:50:27 UTC
oVirt gerrit 36550 master MERGED Update only name and address fields when picking foreman parameters Never
oVirt gerrit 36631 ovirt-engine-3.5 MERGED Update only name and address fields when picking foreman parameters Never

Description Yaniv Bronhaim 2015-01-01 11:51:17 UTC
Description of problem:
by default "Use JSON protocol" is enabled. when clicking on "Use Foreman Hosts Providers" we automatically disable "Use JSON protocol". clicking again (disabling) "Use Foreman Hosts Providers" leaves "Use JSON Protocol" disabled.


Version-Release number of selected component (if applicable):
vt13

How reproducible:
100%

Actual results:
"Use JSON Protocol" is disabled

Expected results:
keep "Use JSON Protocol" value as default.

Comment 1 Yaniv Bronhaim 2015-01-02 05:18:23 UTC
The UI default is to enable Json Protocol, but VDS object default for vds.protocol is XML. therefore, when choosing discovered host we set the AddHost form with vds defaults before choosing the host to discover. The initial form values are cleaned, so UI default doesn't really catch.

It is not a bug or the fix should be to set Json Protocol as default for VDS object. Any problems with doing that?

Comment 2 Piotr Kliczewski 2015-01-03 09:28:34 UTC
It looks like a bug. Default protocol should be set based on cluster level. Other than that it is ok to set json protocol as default.

Comment 3 movciari 2015-01-20 13:27:14 UTC
org.ovirt.engine-root-3.5.0-30 doesn't seem like version of rpm...
could you provide version of rpm where this is fixed so i test it on correct version, please?

Comment 5 Eyal Edri 2015-02-15 09:14:18 UTC
bugs were moved by ERRATA to RELEASE PENDING bug not closed probably due to errata error.
closing as 3.5.0 is released.


Note You need to log in before you can comment on or make changes to this bug.