Bug 1178046 - Bulk Action Errata only applies foreman entries_per_page number of errata
Summary: Bulk Action Errata only applies foreman entries_per_page number of errata
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: sthirugn@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-01 19:54 UTC by Paul Armstrong
Modified: 2019-10-10 09:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:12:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Paul Armstrong 2015-01-01 19:54:59 UTC
Description of problem: 
When performing a bulk action to apply errata to a given set of hosts, the task created only applies 'foreman entries_per_page' number of errata to the selected systems

Version-Release number of selected component (if applicable):6.0.4

How reproducible: Always


Steps to Reproduce:
1. In WebUI. Administer -> Settings -> General -> entries_per_page. Edit value to 5. Save settings.

2. Navigate to the Content Hosts view. Select multiple systems (in my case they were identical with identical number of errata). Select Bulk Actions -> Errata

3. Scroll list of Errata to fully populate list for the selected systems.

4. Select all errata by clicking the 'select all' checkbox at the top of the table. List should show all selected. Heading should say (multiple of entries_per_page) of n errata selected. (See 1157294)

5. Select 'Apply Selected'. Select "yes' to apply the errata ... processing... you will receive message that a multiple of entries_per_page errata have been scheduled for installation.

6. Wait for process to complete and the systems to check in again.

Actual results:

Not all errata are applied. Checking the number of errata remaining shows that only entries_per_page number of errata were applied. This occurs no matter how many entries are selected as long as that number is greater than entries_per_page. Selecting consecutive entries individually from the list has no effect. i.e. selecting 6 consecutive entries from the top applies only the first 5. Selecting more than entries_per_page random entries also has no effect, only entries from the first set of entries_per_page are applied.

Expected results:

All selected errata are applied regardless of the value of entries_per_page, order selection or other conceivable selection variations.



Additional info:

Comment 1 RHEL Product and Program Management 2015-01-01 20:24:02 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Brad Buckingham 2015-09-08 19:36:43 UTC
I have tested this on a Satellite 6.1.1 GA install and am no longer observing
the behavior described.  Moving to ON_QA for verification.

RPMs:
ruby193-rubygem-katello-2.2.0.66-1.el7sat.noarch
foreman-1.7.2.34-1.el7sat.noarch

Comment 5 sthirugn@redhat.com 2016-04-22 19:26:35 UTC
Verified in Satellite-6.2-beta-snap-9.1.

I applied 67 erratas to 2 content hosts - all errata got applied.  After installation, I refreshed content hosts page and noticed Installable Errata = 0

Comment 7 errata-xmlrpc 2016-07-27 09:12:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.